summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn D Jones III2015-06-16 15:57:54 -0600
committerJohn D Jones III2015-06-16 15:57:54 -0600
commit47398c228fb8e273322faf4f3357124fd3213bbd (patch)
tree20a2d5b7d2accc40c99ff48ce19c8f1834f4d647
downloadaur-47398c228fb8e273322faf4f3357124fd3213bbd.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD50
2 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c25bbde1aa4b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = perl-tcl
+ pkgdesc = Tcl extension module for Perl
+ pkgver = 1.02
+ pkgrel = 1
+ url = http://search.cpan.org/dist/Tcl
+ arch = i686
+ arch = x86_64
+ license = PerlArtistic
+ license = GPL
+ depends = perl>=5.006
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/V/VK/VKON/Tcl-1.02.tar.gz
+ md5sums = e3fb55e44e9013751b4bc6f6173c3048
+ sha512sums = bcd1430526ace01092465f0bed9ff4c5d6966fb81231fbd278ab49d9902774a7d7d81ff0926c6432e861d89e36e3de122611542c25c9226f7623a62c977f4ed6
+
+pkgname = perl-tcl
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c29a72e92859
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Contributor: John D Jones III <j[nospace]n[nospace]b[nospace]e[nospace]k[nospace]1972 -_AT_- the domain name google offers a mail service at ending in dot com>
+# Generator : CPANPLUS::Dist::Arch 1.25
+
+pkgname='perl-tcl'
+pkgver='1.02'
+pkgrel='1'
+pkgdesc="Tcl extension module for Perl"
+arch=('i686' 'x86_64')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl>=5.006')
+makedepends=()
+url='http://search.cpan.org/dist/Tcl'
+source=('http://search.cpan.org/CPAN/authors/id/V/VK/VKON/Tcl-1.02.tar.gz')
+md5sums=('e3fb55e44e9013751b4bc6f6173c3048')
+sha512sums=('bcd1430526ace01092465f0bed9ff4c5d6966fb81231fbd278ab49d9902774a7d7d81ff0926c6432e861d89e36e3de122611542c25c9226f7623a62c977f4ed6')
+_distdir="Tcl-1.02"
+
+build() {
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "$srcdir/$_distdir"
+ /usr/bin/perl Makefile.PL
+ make
+ )
+}
+
+check() {
+ cd "$srcdir/$_distdir"
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+ make test
+ )
+}
+
+package() {
+ cd "$srcdir/$_distdir"
+ make install
+
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
+
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
+# vim:set ts=2 sw=2 et: