summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnton Leontiev2013-08-23 16:58:29 +0400
committerAnton Leontiev2015-02-15 07:48:01 +0300
commit0506489b453b247ed3609fa1005216faa091f902 (patch)
tree935d5398cc9ff7d56179362f00f0ab1b9574ec75
downloadaur-0506489b453b247ed3609fa1005216faa091f902.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD35
-rw-r--r--PKGBUILD.tt35
4 files changed, 96 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..57a13b48d0ce
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = perl-test-class
+ pkgdesc = Perl module to easily create test classes in an xUnit/JUnit style
+ pkgver = 0.39
+ pkgrel = 1
+ url = http://search.cpan.org/dist/Test-Class
+ arch = any
+ license = GPL
+ checkdepends = perl-test-exception
+ checkdepends = perl-test-most
+ makedepends = perl-extutils-pkgconfig
+ depends = perl>=5.8.9
+ depends = perl-attribute-handlers>=0.77
+ depends = perl-test-simple
+ depends = perl-mro-compat>=0.11
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/A/AD/ADIE/Test-Class-0.39.tar.gz
+ md5sums = f296e57ede695bff76e4f1336e4c49d3
+
+pkgname = perl-test-class
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e6b6b4b8077d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+*.tar.gz
+*.tar.bz2
+*.tar.xz
+*.tar.lz
+src/
+pkg/ \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d790e2195f52
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# CPAN Name : Test::Class
+# Contributor: Anton Leontiev <bunder /at/ t-25.ru>
+# Generator : CPANPLUS::Dist::Arch 1.25
+
+pkgname=perl-test-class
+pkgver=0.39
+pkgrel=1
+pkgdesc='Perl module to easily create test classes in an xUnit/JUnit style'
+arch=('any')
+url='http://search.cpan.org/dist/Test-Class'
+license=('GPL')
+options=(!emptydirs)
+depends=('perl>=5.8.9' 'perl-attribute-handlers>=0.77' 'perl-test-simple'
+ 'perl-mro-compat>=0.11')
+makedepends=('perl-extutils-pkgconfig')
+checkdepends=('perl-test-exception' 'perl-test-most')
+source=(http://search.cpan.org/CPAN/authors/id/A/AD/ADIE/Test-Class-0.39.tar.gz)
+md5sums=('f296e57ede695bff76e4f1336e4c49d3')
+
+build() {
+ cd "$srcdir/Test-Class-0.39"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ cd "$srcdir/Test-Class-0.39"
+ make test
+}
+
+package() {
+ cd "$srcdir/Test-Class-0.39"
+ make install DESTDIR="$pkgdir"
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
diff --git a/PKGBUILD.tt b/PKGBUILD.tt
new file mode 100644
index 000000000000..259107dd5ea5
--- /dev/null
+++ b/PKGBUILD.tt
@@ -0,0 +1,35 @@
+# CPAN Name : Test::Class
+# Contributor: [% packager %]
+# Generator : CPANPLUS::Dist::Arch [% version %]
+
+pkgname=[% pkgname %]
+pkgver=[% pkgver %]
+pkgrel=[% pkgrel %]
+pkgdesc='Perl module to easily create test classes in an xUnit/JUnit style'
+arch=('any')
+url='[% url %]'
+license=('GPL')
+options=(!emptydirs)
+depends=('perl>=5.8.9' 'perl-attribute-handlers>=0.77' 'perl-test-simple'
+ 'perl-mro-compat>=0.11')
+makedepends=('perl-extutils-pkgconfig')
+checkdepends=('perl-test-exception' 'perl-test-most')
+source=([% source %])
+md5sums=('[% md5sums %]')
+
+build() {
+ cd "$srcdir/[% distdir %]"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ cd "$srcdir/[% distdir %]"
+ make test
+}
+
+package() {
+ cd "$srcdir/[% distdir %]"
+ make install DESTDIR="$pkgdir"
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}