summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnton Leontiev2014-10-26 21:09:06 +0300
committerAnton Leontiev2015-02-15 07:48:24 +0300
commit519cfe18205268227baf7df7eefff2afddf63fa7 (patch)
treef3a083615deb5b10e798c1d13851345babc3cb3b
parent7e6ac2ec4faed9f68909d1960aaa73b7be0aff9f (diff)
downloadaur-519cfe18205268227baf7df7eefff2afddf63fa7.tar.gz
Updated to v0.47
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD27
-rw-r--r--PKGBUILD.tt13
3 files changed, 30 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 008f30c05d42..d64d50146358 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,17 @@
pkgbase = perl-test-class
pkgdesc = Perl module to easily create test classes in an xUnit/JUnit style
- pkgver = 0.41
+ pkgver = 0.47
pkgrel = 1
url = http://search.cpan.org/dist/Test-Class
arch = any
license = GPL
- checkdepends = perl-test-exception
- checkdepends = perl-test-most
- makedepends = perl-extutils-pkgconfig
- depends = perl>=5.8.9
+ checkdepends = perl-test-exception>=0.25
+ depends = perl>=5.19.6
depends = perl-attribute-handlers>=0.77
depends = perl-mro-compat>=0.11
options = !emptydirs
- source = http://search.cpan.org/CPAN/authors/id/R/RJ/RJBS/Test-Class-0.41.tar.gz
- md5sums = 56358ad7d53a496865033c1a6dd5a162
+ source = http://search.cpan.org/CPAN/authors/id/E/ET/ETHER/Test-Class-0.47.tar.gz
+ md5sums = 952f7ee1f490760a99e812eea33c053c
pkgname = perl-test-class
diff --git a/PKGBUILD b/PKGBUILD
index 82ec9b72b5a3..1bf9e6f44f59 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,41 @@
# CPAN Name : Test::Class
# Contributor: Anton Leontiev <bunder /at/ t-25.ru>
-# Generator : CPANPLUS::Dist::Arch 1.28
+# Generator : CPANPLUS::Dist::Arch 1.29
pkgname=perl-test-class
-pkgver=0.41
+pkgver=0.47
pkgrel=1
pkgdesc='Perl module to easily create test classes in an xUnit/JUnit style'
arch=('any')
url='http://search.cpan.org/dist/Test-Class'
license=('GPL')
options=(!emptydirs)
-depends=('perl>=5.8.9'
+depends=('perl>=5.19.6'
'perl-attribute-handlers>=0.77'
'perl-mro-compat>=0.11')
-makedepends=('perl-extutils-pkgconfig')
-checkdepends=('perl-test-exception' 'perl-test-most')
-source=(http://search.cpan.org/CPAN/authors/id/R/RJ/RJBS/Test-Class-0.41.tar.gz)
-md5sums=('56358ad7d53a496865033c1a6dd5a162')
+checkdepends=(
+ 'perl-test-exception>=0.25')
+source=(http://search.cpan.org/CPAN/authors/id/E/ET/ETHER/Test-Class-0.47.tar.gz)
+md5sums=('952f7ee1f490760a99e812eea33c053c')
build() {
- cd Test-Class-0.41
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ cd Test-Class-0.47
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps
+ /usr/bin/perl Makefile.PL INSTALLDIRS=vendor
make
}
check() {
- cd Test-Class-0.41
+ cd Test-Class-0.47
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1
make test
}
package() {
- cd Test-Class-0.41
+ cd Test-Class-0.47
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
make install DESTDIR="$pkgdir"
find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
}
diff --git a/PKGBUILD.tt b/PKGBUILD.tt
index ddd90bd2963f..61c0e29723a0 100644
--- a/PKGBUILD.tt
+++ b/PKGBUILD.tt
@@ -10,27 +10,32 @@ arch=('any')
url='[% url %]'
license=('GPL')
options=(!emptydirs)
-depends=('perl>=5.8.9'
+depends=('perl>=5.19.6'
'perl-attribute-handlers>=0.77'
'perl-mro-compat>=0.11')
-makedepends=('perl-extutils-pkgconfig')
-checkdepends=('perl-test-exception' 'perl-test-most')
+checkdepends=(
+ 'perl-test-exception>=0.25')
source=([% source %])
md5sums=('[% md5sums %]')
build() {
cd [% distdir %]
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps
+ /usr/bin/perl Makefile.PL INSTALLDIRS=vendor
make
}
check() {
cd [% distdir %]
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1
make test
}
package() {
cd [% distdir %]
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
make install DESTDIR="$pkgdir"
find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
}