summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnton Leontiev2013-11-10 18:34:34 +0400
committerAnton Leontiev2015-02-15 07:48:19 +0300
commitfda78f95d13eae25c60f83c2889ad078ac429910 (patch)
treeba3165d873261ce76e155c64a374e1092cb2d5fc
parent0506489b453b247ed3609fa1005216faa091f902 (diff)
downloadaur-fda78f95d13eae25c60f83c2889ad078ac429910.tar.gz
Updated to v0.40
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD27
-rw-r--r--PKGBUILD.tt19
3 files changed, 27 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 57a13b48d0ce..3e87b28de892 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = perl-test-class
pkgdesc = Perl module to easily create test classes in an xUnit/JUnit style
- pkgver = 0.39
+ pkgver = 0.40
pkgrel = 1
url = http://search.cpan.org/dist/Test-Class
arch = any
@@ -10,11 +10,10 @@ pkgbase = perl-test-class
makedepends = perl-extutils-pkgconfig
depends = perl>=5.8.9
depends = perl-attribute-handlers>=0.77
- depends = perl-test-simple
depends = perl-mro-compat>=0.11
options = !emptydirs
- source = http://search.cpan.org/CPAN/authors/id/A/AD/ADIE/Test-Class-0.39.tar.gz
- md5sums = f296e57ede695bff76e4f1336e4c49d3
+ source = http://search.cpan.org/CPAN/authors/id/R/RJ/RJBS/Test-Class-0.40.tar.gz
+ md5sums = 22e4387daec4117c8a56767790059951
pkgname = perl-test-class
diff --git a/PKGBUILD b/PKGBUILD
index d790e2195f52..0cf7e1b8d09b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,36 @@
# CPAN Name : Test::Class
# Contributor: Anton Leontiev <bunder /at/ t-25.ru>
-# Generator : CPANPLUS::Dist::Arch 1.25
+# Generator : CPANPLUS::Dist::Arch 1.28
pkgname=perl-test-class
-pkgver=0.39
+pkgver=0.40
pkgrel=1
pkgdesc='Perl module to easily create test classes in an xUnit/JUnit style'
arch=('any')
url='http://search.cpan.org/dist/Test-Class'
license=('GPL')
options=(!emptydirs)
-depends=('perl>=5.8.9' 'perl-attribute-handlers>=0.77' 'perl-test-simple'
+depends=('perl>=5.8.9'
+ 'perl-attribute-handlers>=0.77'
'perl-mro-compat>=0.11')
makedepends=('perl-extutils-pkgconfig')
checkdepends=('perl-test-exception' 'perl-test-most')
-source=(http://search.cpan.org/CPAN/authors/id/A/AD/ADIE/Test-Class-0.39.tar.gz)
-md5sums=('f296e57ede695bff76e4f1336e4c49d3')
+source=(http://search.cpan.org/CPAN/authors/id/R/RJ/RJBS/Test-Class-0.40.tar.gz)
+md5sums=('22e4387daec4117c8a56767790059951')
build() {
- cd "$srcdir/Test-Class-0.39"
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
- make
+ cd Test-Class-0.40
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
}
check() {
- cd "$srcdir/Test-Class-0.39"
- make test
+ cd Test-Class-0.40
+ make test
}
package() {
- cd "$srcdir/Test-Class-0.39"
- make install DESTDIR="$pkgdir"
- find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+ cd Test-Class-0.40
+ make install DESTDIR="$pkgdir"
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
}
diff --git a/PKGBUILD.tt b/PKGBUILD.tt
index 259107dd5ea5..ddd90bd2963f 100644
--- a/PKGBUILD.tt
+++ b/PKGBUILD.tt
@@ -10,7 +10,8 @@ arch=('any')
url='[% url %]'
license=('GPL')
options=(!emptydirs)
-depends=('perl>=5.8.9' 'perl-attribute-handlers>=0.77' 'perl-test-simple'
+depends=('perl>=5.8.9'
+ 'perl-attribute-handlers>=0.77'
'perl-mro-compat>=0.11')
makedepends=('perl-extutils-pkgconfig')
checkdepends=('perl-test-exception' 'perl-test-most')
@@ -18,18 +19,18 @@ source=([% source %])
md5sums=('[% md5sums %]')
build() {
- cd "$srcdir/[% distdir %]"
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
- make
+ cd [% distdir %]
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
}
check() {
- cd "$srcdir/[% distdir %]"
- make test
+ cd [% distdir %]
+ make test
}
package() {
- cd "$srcdir/[% distdir %]"
- make install DESTDIR="$pkgdir"
- find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+ cd [% distdir %]
+ make install DESTDIR="$pkgdir"
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
}