summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMoritz Bunkus2023-01-07 23:44:01 +0100
committerMoritz Bunkus2023-01-07 23:44:01 +0100
commit2a5a91b8094e0847ea89ff0b57988704cfe9c7c4 (patch)
tree7a4f636f42b34b128513584e5ebf85e558103497
parenta2dab3fdaefd7e459a342b72299789682a9d3290 (diff)
downloadaur-2a5a91b8094e0847ea89ff0b57988704cfe9c7c4.tar.gz
adopt package; adjust to my style; update to 0.25
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD46
2 files changed, 25 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 363f05c13cf7..77f666d24d4c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,14 @@
pkgbase = perl-test-cpan-meta
pkgdesc = Validate your CPAN META.yml files.
- pkgver = 0.24
+ pkgver = 0.25
pkgrel = 1
- url = https://metacpan.org/release/Test-CPAN-Meta
+ url = https://metacpan.org/pod/Test::CPAN::Meta
arch = any
license = PerlArtistic
license = GPL
depends = perl
options = !emptydirs
- source = http://search.cpan.org/CPAN/authors/id/B/BA/BARBIE/Test-CPAN-Meta-0.24.tar.gz
- md5sums = b91f2d47eff5945fa40ca0ce62efa4af
- sha512sums = b81ee69ceef6bb2e43dc3efffd732832e480af5bc55fef31c63d3fbef0e2c92244925ecfb649db5dfa21ae4e7773f41a5e6a96f0282c6f65c325b51a7cfaaf84
+ source = https://cpan.metacpan.org/authors/id/B/BA/BARBIE/Test-CPAN-Meta-0.25.tar.gz
+ sha512sums = 60a3414e1e0f9aaa1a9459aedd76a6d937742a4197d0d5ce9330348138997d372ca3f454c262fb6dd757699168aa7d1c2653c4066060c9c5685a6fe407260580
pkgname = perl-test-cpan-meta
-
diff --git a/PKGBUILD b/PKGBUILD
index a0c0e80d5688..283a349a816a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,7 @@
-# Contributor: John D Jones III AKA jnbek <jnbek1972 -_AT_- g m a i l -_Dot_- com>
-# Generator : CPANPLUS::Dist::Arch 1.30
+# Maintainer: Moritz Bunkus <moritz@bunkus.org>
pkgname='perl-test-cpan-meta'
-pkgver='0.24'
+pkgver='0.25'
pkgrel='1'
pkgdesc="Validate your CPAN META.yml files."
arch=('any')
@@ -10,37 +9,34 @@ license=('PerlArtistic' 'GPL')
options=('!emptydirs')
depends=('perl')
makedepends=()
-url='https://metacpan.org/release/Test-CPAN-Meta'
-source=('http://search.cpan.org/CPAN/authors/id/B/BA/BARBIE/Test-CPAN-Meta-0.24.tar.gz')
-md5sums=('b91f2d47eff5945fa40ca0ce62efa4af')
-sha512sums=('b81ee69ceef6bb2e43dc3efffd732832e480af5bc55fef31c63d3fbef0e2c92244925ecfb649db5dfa21ae4e7773f41a5e6a96f0282c6f65c325b51a7cfaaf84')
-_distdir="Test-CPAN-Meta-0.24"
+url='https://metacpan.org/pod/Test::CPAN::Meta'
+source=("https://cpan.metacpan.org/authors/id/B/BA/BARBIE/Test-CPAN-Meta-${pkgver}.tar.gz")
+sha512sums=('60a3414e1e0f9aaa1a9459aedd76a6d937742a4197d0d5ce9330348138997d372ca3f454c262fb6dd757699168aa7d1c2653c4066060c9c5685a6fe407260580')
-build() {
- ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
- PERL_AUTOINSTALL=--skipdeps \
- PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
- PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
- MODULEBUILDRC=/dev/null
+prepare_environment() {
+ export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+ cd "${srcdir}/Test-CPAN-Meta-${pkgver}"
+}
- cd "$srcdir/$_distdir"
- /usr/bin/perl Makefile.PL
- make
- )
+build() {
+ prepare_environment
+ /usr/bin/perl Makefile.PL
+ make
}
check() {
- cd "$srcdir/$_distdir"
- ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
- make test
- )
+ prepare_environment
+ make test
}
package() {
- cd "$srcdir/$_distdir"
+ prepare_environment
make install
-
- find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+ find "$pkgdir" "(" -name .packlist -o -name perllocal.pod ")" -delete
}
# Local Variables: