summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnton Leontiev2016-05-05 20:51:27 +0300
committerAnton Leontiev2016-05-05 20:51:27 +0300
commit9e9788da09d196d7973d5ae921c9510d99f38275 (patch)
tree8fad88ba359d0356d5000476a752f28ca339840b
downloadaur-9e9788da09d196d7973d5ae921c9510d99f38275.tar.gz
Initial version v0.01
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD40
-rw-r--r--PKGBUILD.tt40
4 files changed, 103 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..96483a196149
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Thu May 5 17:50:17 UTC 2016
+pkgbase = perl-test-identity
+ pkgdesc = Perl module to test the referential identity of a reference
+ pkgver = 0.01
+ pkgrel = 1
+ url = https://metacpan.org/release/Test-Identity
+ arch = any
+ license = PerlArtistic
+ license = GPL
+ depends = perl
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/P/PE/PEVANS/Test-Identity-0.01.tar.gz
+ md5sums = ecef85c791cf5847e4c374983cf22a74
+
+pkgname = perl-test-identity
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e6b6b4b8077d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+*.tar.gz
+*.tar.bz2
+*.tar.xz
+*.tar.lz
+src/
+pkg/ \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bd0708c3d9c1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# CPAN Name : Test::Identity
+# Contributor: Anonymous
+# Generator : CPANPLUS::Dist::Arch 1.32
+
+pkgname=perl-test-identity
+pkgver=0.01
+pkgrel=1
+pkgdesc='Perl module to test the referential identity of a reference'
+arch=('any')
+url='https://metacpan.org/release/Test-Identity'
+license=('PerlArtistic' 'GPL')
+depends=('perl')
+source=(http://search.cpan.org/CPAN/authors/id/P/PE/PEVANS/Test-Identity-0.01.tar.gz)
+options=(!emptydirs)
+md5sums=('ecef85c791cf5847e4c374983cf22a74')
+
+sanitize() {
+ unset PERL5LIB PERL_MM_OPT PERL_MB_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1 MODULEBUILDRC=/dev/null
+}
+
+build() {
+ cd Test-Identity-0.01
+ sanitize
+ perl Build.PL --installdirs vendor --destdir "$pkgdir"
+ perl Build
+}
+
+check() {
+ cd Test-Identity-0.01
+ sanitize
+ perl Build test
+}
+
+package() {
+ cd Test-Identity-0.01
+ sanitize
+ perl Build install
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
diff --git a/PKGBUILD.tt b/PKGBUILD.tt
new file mode 100644
index 000000000000..c46d4faf324c
--- /dev/null
+++ b/PKGBUILD.tt
@@ -0,0 +1,40 @@
+# CPAN Name : Test::Identity
+# Contributor: [% packager %]
+# Generator : CPANPLUS::Dist::Arch [% version %]
+
+pkgname=[% pkgname %]
+pkgver=[% pkgver %]
+pkgrel=[% pkgrel %]
+pkgdesc='Perl module to test the referential identity of a reference'
+arch=('any')
+url='[% url %]'
+license=('PerlArtistic' 'GPL')
+depends=('perl')
+source=([% source %])
+options=(!emptydirs)
+md5sums=('[% md5sums %]')
+
+sanitize() {
+ unset PERL5LIB PERL_MM_OPT PERL_MB_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1 MODULEBUILDRC=/dev/null
+}
+
+build() {
+ cd [% distdir %]
+ sanitize
+ perl Build.PL --installdirs vendor --destdir "$pkgdir"
+ perl Build
+}
+
+check() {
+ cd [% distdir %]
+ sanitize
+ perl Build test
+}
+
+package() {
+ cd [% distdir %]
+ sanitize
+ perl Build install
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}