aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Göbel2017-03-31 18:30:59 +0200
committerStefan Göbel2017-03-31 18:30:59 +0200
commit3871ad028379114f2e36a1d16de3ff9a7b45f038 (patch)
tree824f5a525c90ae095927f51aeb309b429daebd6a
downloadaur-3871ad028379114f2e36a1d16de3ff9a7b45f038.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD46
-rw-r--r--README4
3 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7474f0875767
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = perl-test-lectrotest
+ pkgdesc = Easy, automatic, specification-based tests.
+ pkgver = 0.5001
+ pkgrel = 1
+ url = https://metacpan.org/release/Test-LectroTest
+ arch = any
+ license = PerlArtistic
+ license = GPL
+ options = !emptydirs
+ options = purge
+ source = http://search.cpan.org/CPAN/authors/id/T/TM/TMOERTEL/Test-LectroTest-0.5001.tar.gz
+ sha256sums = ac2b4f0d95899af1a1a1ec784cb740b2b90256abee11c83e7b291103ec9ed735
+
+pkgname = perl-test-lectrotest
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..043a522dcf6d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Stefan Göbel <aur —at— subtype —dot— de>
+
+pkgname='perl-test-lectrotest'
+_module='Test-LectroTest'
+_author='T/TM/TMOERTEL'
+pkgver='0.5001'
+pkgrel='1'
+pkgdesc='Easy, automatic, specification-based tests.'
+arch=('any')
+url="https://metacpan.org/release/$_module"
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs' 'purge')
+source=("http://search.cpan.org/CPAN/authors/id/$_author/$_module-$pkgver.tar.gz")
+sha256sums=('ac2b4f0d95899af1a1a1ec784cb740b2b90256abee11c83e7b291103ec9ed735')
+
+build() {
+ (
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT='1' PERL_AUTOINSTALL='--skipdeps'
+ cd "$_module-$pkgver"
+ /usr/bin/perl Makefile.PL INSTALLDIRS='vendor'
+ make
+ )
+}
+
+check() {
+ (
+ cd "$_module-$pkgver"
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT='1'
+ make test
+ )
+}
+
+package() {
+ (
+ cd "$_module-$pkgver"
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ make install INSTALLDIRS='vendor' DESTDIR="$pkgdir"
+ find "$pkgdir" -name .packlist -delete
+ find "$pkgdir" -name perllocal.pod -delete
+ find "$pkgdir" -type d -empty -delete
+ )
+}
+
+#:indentSize=3:tabSize=3:noTabs=true:mode=shellscript:maxLineLen=87: \ No newline at end of file
diff --git a/README b/README
new file mode 100644
index 000000000000..e047c14386ca
--- /dev/null
+++ b/README
@@ -0,0 +1,4 @@
+This repository contains the PKGBUILD to create the «perl-test-lectrotest»
+package for the Perl module Test::LectroTest for Arch Linux.
+
+See https://aur.archlinux.org/packages/perl-test-lectrotest/. \ No newline at end of file