summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxRemaLx2015-10-02 04:32:55 +0300
committerxRemaLx2015-10-02 04:32:55 +0300
commit9e5d7b20d786d426f0e187e5b00a36cd57d5811d (patch)
tree1f9b1fb764c157a8306bc26d886d825eb7d66b28
parent946d11049ae394597adf7f4b3d5cef85eabd8d22 (diff)
downloadaur-perl-test-longstring.tar.gz
Update to 0.17
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD48
2 files changed, 27 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 44e8c6e27fa8..4dc1dfbc5e5b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = perl-test-longstring
pkgdesc = tests strings for equality, with more helpful failures
- pkgver = 0.15
- pkgrel = 2
+ pkgver = 0.17
+ pkgrel = 1
url = http://search.cpan.org/dist/Test-LongString
arch = any
- license = PerlArtistic
license = GPL
+ license = PerlArtistic
depends = perl
options = !emptydirs
- source = http://search.cpan.org/CPAN/authors/id/R/RG/RGARCIA/Test-LongString-0.15.tar.gz
- md5sums = e628d735b8e8f33d3992541f823491c3
- sha512sums = d50bcba177280ff6da17720bde03dce0fe2b034aa7eeaa8825ccf983cbb8e60ee8f18179e47cfd43db1cac217bf30c38d224fb3557fb76ab3b58f573fd1ef529
+ options = purge
+ source = http://search.cpan.org/CPAN/authors/id/R/RG/RGARCIA/Test-LongString-0.17.tar.gz
+ sha512sums = 1c0cd6fea35bb72816451ce0790002c9dfb945390bc85d22d04670dd5af7ebbe795307ad361e2615ce4ab4f02a317a3aa5d297f2165bd3b1f6de40b3240f1352
pkgname = perl-test-longstring
diff --git a/PKGBUILD b/PKGBUILD
index ebdedc1a4fe1..427483aa1fbf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,45 +1,39 @@
# Contributor: Justin Davis <jrcd83@gmail.com>
-# Generator : CPANPLUS::Dist::Arch 1.18
+# Contributor: xRemaLx <anton.komolov@gmail.com>
pkgname='perl-test-longstring'
-_pkgname='Test-LongString'
-pkgver='0.15'
-pkgrel='2'
+pkgver='0.17'
+pkgrel='1'
pkgdesc="tests strings for equality, with more helpful failures"
+_dist='Test-LongString'
arch=('any')
-license=('PerlArtistic' 'GPL')
-options=('!emptydirs')
+url='http://search.cpan.org/dist/Test-LongString'
+license=('GPL' 'PerlArtistic')
depends=('perl')
+options=('!emptydirs' purge)
makedepends=()
-url='http://search.cpan.org/dist/Test-LongString'
-source=("http://search.cpan.org/CPAN/authors/id/R/RG/RGARCIA/${_pkgname}-${pkgver}.tar.gz")
-md5sums=('e628d735b8e8f33d3992541f823491c3')
-sha512sums=('d50bcba177280ff6da17720bde03dce0fe2b034aa7eeaa8825ccf983cbb8e60ee8f18179e47cfd43db1cac217bf30c38d224fb3557fb76ab3b58f573fd1ef529')
+source=("http://search.cpan.org/CPAN/authors/id/R/RG/RGARCIA/${_dist}-${pkgver}.tar.gz")
+sha512sums=('1c0cd6fea35bb72816451ce0790002c9dfb945390bc85d22d04670dd5af7ebbe795307ad361e2615ce4ab4f02a317a3aa5d297f2165bd3b1f6de40b3240f1352')
build() {
- ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
- PERL_AUTOINSTALL=--skipdeps \
- PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
- PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
- MODULEBUILDRC=/dev/null
-
- cd "${srcdir}/${_pkgname}-${pkgver}"
- /usr/bin/perl Makefile.PL
- make
- )
+ cd "${srcdir}/${_dist}-${pkgver}"
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps
+ /usr/bin/perl Makefile.PL
+ make
}
check() {
- cd "${srcdir}/${_pkgname}-${pkgver}"
- ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
- make test
- )
+ cd "${srcdir}/${_dist}-${pkgver}"
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1
+ make test
}
package() {
- cd "${srcdir}/${_pkgname}-${pkgver}"
- make install
- find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+ cd "${srcdir}/${_dist}-${pkgver}"
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ make install INSTALLDIRS=vendor DESTDIR="$pkgdir"
}
# Local Variables: