summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2021-06-19 11:46:14 +0300
committerCaleb Maclennan2021-06-19 11:46:14 +0300
commit1f9202803b9fbc0c181c7d5af53a78c7a486aa20 (patch)
treea3cc9c65f8ac257d6da9072cddd6c59079f125d3
parentdce43d95a7b4af8b3dead844bda296a915d36d20 (diff)
downloadaur-1f9202803b9fbc0c181c7d5af53a78c7a486aa20.tar.gz
upgpkg: perl-test-most 0.37-2
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD35
2 files changed, 20 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e416f93ba119..2784ed52f987 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = perl-test-most
pkgdesc = Most commonly needed test functions and features
pkgver = 0.37
- pkgrel = 1
+ pkgrel = 2
url = https://metacpan.org/release/Test-Most
arch = any
license = PerlArtistic
license = GPL
+ depends = perl
depends = perl-exception-class
depends = perl-test-deep
depends = perl-test-differences
@@ -15,4 +16,3 @@ pkgbase = perl-test-most
sha256sums = 533370141eb9f18cf4ac380f6ded2ab57802a6e184008a80fd2304bfcc474fc7
pkgname = perl-test-most
-
diff --git a/PKGBUILD b/PKGBUILD
index 4ca70bdd970f..9e5fa37d638d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,33 +4,34 @@
_distname=Test-Most
pkgname=perl-${_distname,,}
pkgver=0.37
-pkgrel=1
+pkgrel=2
pkgdesc='Most commonly needed test functions and features'
-arch=('any')
+arch=(any)
url='https://metacpan.org/release/Test-Most'
-license=('PerlArtistic' 'GPL')
-depends=('perl-exception-class' 'perl-test-deep' 'perl-test-differences' 'perl-test-exception' 'perl-test-warn')
+license=(PerlArtistic GPL)
+_perl_deps=(exception-class test-deep test-differences test-exception test-warn)
+depends=(perl "${_perl_deps[@]/#/perl-}")
source=("https://search.cpan.org/CPAN/authors/id/O/OV/OVID/$_distname-$pkgver.tar.gz")
sha256sums=('533370141eb9f18cf4ac380f6ded2ab57802a6e184008a80fd2304bfcc474fc7')
build() {
- cd "$_distname-$pkgver"
- export PERL_MM_USE_DEFAULT=1 PERL5LIB="" PERL_AUTOINSTALL=--skipdeps \
- PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
- PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
- MODULEBUILDRC=/dev/null
- perl Makefile.PL
- make
+ cd "$_distname-$pkgver"
+ export PERL_MM_USE_DEFAULT=1 PERL5LIB="" PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+ perl Makefile.PL
+ make
}
check() {
- cd "$_distname-$pkgver"
- export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
- make test
+ cd "$_distname-$pkgver"
+ export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+ make test
}
package() {
- cd "$_distname-$pkgver"
- make install
- find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+ cd "$_distname-$pkgver"
+ make install
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
}