summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoréclairevoyant2023-02-20 20:06:46 -0500
committeréclairevoyant2023-02-20 20:06:46 -0500
commit31a9c791cc4bc1e103dbe37ee9723d04f9d0d2eb (patch)
treec3f609b0ce6e900ff21f80b3961062fe1e3a465d
parentaec50d08e19aa38708e8dac747a034ad8f98f2ac (diff)
downloadaur-31a9c791cc4bc1e103dbe37ee9723d04f9d0d2eb.tar.gz
perl-test-refcount: update build process, cleanup, upgpkg 0.10
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD58
3 files changed, 31 insertions, 44 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 350e01856f81..325509fa30a2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,15 @@
-# Generated by mksrcinfo v8
-# Sun Apr 24 00:00:51 UTC 2016
pkgbase = perl-test-refcount
- pkgdesc = assert reference counts on objects
- pkgver = 0.08
+ pkgdesc = Assert reference counts on objects
+ pkgver = 0.10
pkgrel = 1
url = https://metacpan.org/release/Test-Refcount
arch = any
license = PerlArtistic
license = GPL
+ makedepends = perl-module-build
depends = perl
options = !emptydirs
- source = http://search.cpan.org/CPAN/authors/id/P/PE/PEVANS/Test-Refcount-0.08.tar.gz
- md5sums = bcf11e5f0103568674bcc15d2168932e
- sha512sums = 9a5ffe332f9a61c2f019963f49117f4a6af0b855371cd6aa24cc5e3edd7ee6caa54f25bcdd1edf57044c764030f8db37a1ee232d49130656643135cfac96d570
+ source = https://cpan.metacpan.org/authors/id/P/PE/PEVANS/Test-Refcount-0.10.tar.gz
+ b2sums = b0bbcf012254be30d8ff4493cb4fcc01d3f932c812d4812cf167bd45dccab4d4948b7e247c4cba699d9b7aae6a619b4ee65c4827620b1c425f9f8fded88310b7
pkgname = perl-test-refcount
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
index 8b3b59a5f6d9..bc2e5854ff06 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,50 +1,36 @@
-# Contributor: John D Jones III AKA jnbek <jnbek1972 -_AT_- g m a i l -_Dot_- com>
-# Generator : CPANPLUS::Dist::Arch 1.32
+# Maintainer: éclairevoyant
-pkgname='perl-test-refcount'
-pkgver='0.08'
-pkgrel='1'
-pkgdesc="assert reference counts on objects"
+_dist=Test-Refcount
+pkgname=perl-test-refcount
+pkgver=0.10
+pkgrel=1
+pkgdesc="Assert reference counts on objects"
arch=('any')
license=('PerlArtistic' 'GPL')
options=('!emptydirs')
depends=('perl')
-makedepends=()
-url='https://metacpan.org/release/Test-Refcount'
-source=('http://search.cpan.org/CPAN/authors/id/P/PE/PEVANS/Test-Refcount-0.08.tar.gz')
-md5sums=('bcf11e5f0103568674bcc15d2168932e')
-sha512sums=('9a5ffe332f9a61c2f019963f49117f4a6af0b855371cd6aa24cc5e3edd7ee6caa54f25bcdd1edf57044c764030f8db37a1ee232d49130656643135cfac96d570')
-_distdir="Test-Refcount-0.08"
+makedepends=('perl-module-build')
+url="https://metacpan.org/release/$_dist"
+source=("https://cpan.metacpan.org/authors/id/P/PE/PEVANS/$_dist-$pkgver.tar.gz")
+b2sums=('b0bbcf012254be30d8ff4493cb4fcc01d3f932c812d4812cf167bd45dccab4d4948b7e247c4cba699d9b7aae6a619b4ee65c4827620b1c425f9f8fded88310b7')
build() {
- ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
- PERL_AUTOINSTALL=--skipdeps \
- PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
- PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
- MODULEBUILDRC=/dev/null
-
- cd "$srcdir/$_distdir"
- /usr/bin/perl Makefile.PL
- make
- )
+ cd $_dist-$pkgver
+ unset PERL5LIB PERL_MM_OPT PERL_MB_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1 MODULEBUILDRC=/dev/null
+ /usr/bin/perl Build.PL
+ ./Build
}
check() {
- cd "$srcdir/$_distdir"
- ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
- make test
- )
+ cd $_dist-$pkgver
+ unset PERL5LIB PERL_MM_OPT PERL_MB_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1
+ ./Build test
}
package() {
- cd "$srcdir/$_distdir"
- make install
-
- find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+ cd $_dist-$pkgver
+ unset PERL5LIB PERL_MM_OPT PERL_MB_OPT PERL_LOCAL_LIB_ROOT
+ ./Build install --installdirs=vendor --destdir="$pkgdir"
}
-
-# Local Variables:
-# mode: shell-script
-# sh-basic-offset: 2
-# End:
-# vim:set ts=2 sw=2 et: