summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMuflone2018-08-12 20:52:07 +0200
committerMuflone2018-08-12 20:52:07 +0200
commitff96c287468225f08b92833273997d234fcd7a7d (patch)
tree318b72b47d9b64caf3b3e251b7c83a0035cc4fdc
parentf0756ec392a4140a91a26d7c72676765b062ede2 (diff)
downloadaur-ff96c287468225f08b92833273997d234fcd7a7d.tar.gz
Updated package perl-test-subcalls 1.09-2
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD61
2 files changed, 35 insertions, 42 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 697dc443c4d8..e1f183b749de 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,18 @@
+# Generated by mksrcinfo v8
+# Sun Aug 12 18:51:04 UTC 2018
pkgbase = perl-test-subcalls
pkgdesc = Track the number of times subs are called
pkgver = 1.09
- pkgrel = 1
- url = http://search.cpan.org/dist/Test-SubCalls
+ pkgrel = 2
+ url = https://metacpan.org/release/Test-SubCalls
arch = any
- license = PerlArtistic
license = GPL
- depends = perl-hook-lexwrap>=0.20
+ license = PerlArtistic
+ makedepends = perl-module-install
+ depends = perl-hook-lexwrap
options = !emptydirs
- source = http://search.cpan.org/CPAN/authors/id/A/AD/ADAMK/Test-SubCalls-1.09.tar.gz
- md5sums = 975a9fe8d93ef0298fc1bca8f03166e1
- sha512sums = d5a5341eb70467c47ea71d54726bf1c5010bca69b30d5347cb682b0feaec7dd17525075b48b48237c256a31cea3b735991e5dea51b8f5d989f09362b11f6dc7a
+ source = https://www.cpan.org/modules/by-module/Test/Test-SubCalls-1.09.tar.gz
+ sha256sums = a334b0457da338d79be2dbb62d403701fc90f7607df840115ff45ee1e2bd6e70
pkgname = perl-test-subcalls
diff --git a/PKGBUILD b/PKGBUILD
index d6df46d53f54..ab8f7240c5c2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,50 +1,41 @@
+# Maintainer: Muflone http://www.muflone.com/contacts/english/
# Contributor: John D Jones III <j[nospace]n[nospace]b[nospace]e[nospace]k[nospace]1972 -_AT_- the domain name google offers a mail service at ending in dot com>
-# Generator : CPANPLUS::Dist::Arch 1.25
-pkgname='perl-test-subcalls'
-pkgver='1.09'
-pkgrel='1'
+pkgname=perl-test-subcalls
+_perl_namespace=Test
+_perl_module=SubCalls
+pkgver=1.09
+pkgrel=2
pkgdesc="Track the number of times subs are called"
arch=('any')
-license=('PerlArtistic' 'GPL')
+url="https://metacpan.org/release/${_perl_namespace}-${_perl_module}"
+license=('GPL' 'PerlArtistic')
+depends=('perl-hook-lexwrap')
+makedepends=('perl-module-install')
+source=("https://www.cpan.org/modules/by-module/${_perl_namespace}/${_perl_namespace}-${_perl_module}-${pkgver}.tar.gz")
+sha256sums=('a334b0457da338d79be2dbb62d403701fc90f7607df840115ff45ee1e2bd6e70')
options=('!emptydirs')
-depends=('perl-hook-lexwrap>=0.20')
-makedepends=()
-url='http://search.cpan.org/dist/Test-SubCalls'
-source=('http://search.cpan.org/CPAN/authors/id/A/AD/ADAMK/Test-SubCalls-1.09.tar.gz')
-md5sums=('975a9fe8d93ef0298fc1bca8f03166e1')
-sha512sums=('d5a5341eb70467c47ea71d54726bf1c5010bca69b30d5347cb682b0feaec7dd17525075b48b48237c256a31cea3b735991e5dea51b8f5d989f09362b11f6dc7a')
-_distdir="Test-SubCalls-1.09"
build() {
- ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
- PERL_AUTOINSTALL=--skipdeps \
- PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
- PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
- MODULEBUILDRC=/dev/null
-
- cd "$srcdir/$_distdir"
- /usr/bin/perl Makefile.PL
- make
- )
+ cd "${_perl_namespace}-${_perl_module}-${pkgver}"
+ unset PERL5LIB PERL_MM_OPT PERL_MB_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps
+ perl Makefile.PL
+ make
}
check() {
- cd "$srcdir/$_distdir"
- ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
- make test
- )
+ cd "${_perl_namespace}-${_perl_module}-${pkgver}"
+ unset PERL5LIB PERL_MM_OPT PERL_MB_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1
+ make test
}
package() {
- cd "$srcdir/$_distdir"
- make install
-
- find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+ cd "${_perl_namespace}-${_perl_module}-${pkgver}"
+ unset PERL5LIB PERL_MM_OPT PERL_MB_OPT PERL_LOCAL_LIB_ROOT
+ make pure_install INSTALLDIRS=vendor DESTDIR="${pkgdir}"
+ # Delete unuseful files
+ find "${pkgdir}" -name '.packlist' -delete
}
-# Local Variables:
-# mode: shell-script
-# sh-basic-offset: 2
-# End:
-# vim:set ts=2 sw=2 et: