summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Lamby2015-06-10 10:15:01 +0200
committerPeter Lamby2015-06-10 10:15:01 +0200
commit55437e6788fd02a597b88d12e6134678d337e24b (patch)
treede3bf610a4f48feb95f80c2a2631c063cce2be5f
downloadaur-55437e6788fd02a597b88d12e6134678d337e24b.tar.gz
Initial import
-rw-r--r--.AURINFO15
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD35
3 files changed, 66 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..a84d0d40e5f3
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,15 @@
+pkgbase = perl-test-tabs
+ pkgdesc = checks the presence of tabs in your project
+ pkgver = 0.005
+ pkgrel = 1
+ url = https://metacpan.org/release/Test-Tabs
+ arch = any
+ license = GPL
+ license = PerlArtistic
+ depends = perl
+ source = http://www.cpan.org/modules/by-module/Test/Test-Tabs-0.005.tar.gz
+ options = !emptydirs
+ options = purge
+
+pkgname = perl-test-tabs
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f27db1c9056f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = perl-test-tabs
+ pkgdesc = checks the presence of tabs in your project
+ pkgver = 0.005
+ pkgrel = 1
+ url = https://metacpan.org/release/Test-Tabs
+ arch = any
+ license = GPL
+ license = PerlArtistic
+ depends = perl
+ options = !emptydirs
+ options = purge
+ source = http://www.cpan.org/modules/by-module/Test/Test-Tabs-0.005.tar.gz
+ md5sums = 5a484f3f8175614faf8d7f19d202a100
+
+pkgname = perl-test-tabs
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0fbd1c1c2453
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Peter Lamby <peterlamby at web dot de>
+pkgname=perl-test-tabs
+pkgver=0.005
+pkgrel=1
+pkgdesc='checks the presence of tabs in your project'
+_dist=Test-Tabs
+arch=('any')
+url="https://metacpan.org/release/$_dist"
+license=('GPL' 'PerlArtistic')
+depends=(perl)
+options=('!emptydirs' purge)
+source=("http://www.cpan.org/modules/by-module/Test/Test-Tabs-$pkgver.tar.gz")
+sha265sums=('716d514e606d81f76f595ce61738f1eb20085429be21eb8af8fba61374a12d2b')
+md5sums=('5a484f3f8175614faf8d7f19d202a100')
+
+build() (
+ cd "$srcdir/$_dist-$pkgver"
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps
+ /usr/bin/perl Makefile.PL
+ make
+)
+
+check() (
+ cd "$srcdir/$_dist-$pkgver"
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1
+ make test
+)
+
+package() (
+ cd "$srcdir/$_dist-$pkgver"
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ make install INSTALLDIRS=vendor DESTDIR="$pkgdir"
+)