summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPappy STĂNESCU2016-10-04 08:29:08 +0300
committerPappy STĂNESCU2016-10-04 08:29:08 +0300
commitc29cd287d1cce9ac4a79b8e974b7ce63abe6f719 (patch)
treef2663e615becb0d71c3b58e934b0c4344cef6248
downloadaur-c29cd287d1cce9ac4a79b8e974b7ce63abe6f719.tar.gz
initial import
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD36
3 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cc1103b138b3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = perl-test-www-mechanize-cgi
+ pkgdesc = Test CGI applications with Test::WWW::Mechanize
+ pkgver = 0.1
+ pkgrel = 1
+ url = http://search.cpan.org/~mramberg/Test-WWW-Mechanize-CGI-0.1
+ arch = any
+ depends = perl-www-mechanize-cgi
+ depends = perl-test-www-mechanize
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/M/MR/MRAMBERG/Test-WWW-Mechanize-CGI-0.1.tar.gz
+ md5sums = 55fea6cdaa85433060c3d55a4982272e
+
+pkgname = perl-test-www-mechanize-cgi
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b5624b74f804
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..846dbe093ec4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Pappy STĂNESCU <pappy _AT_ a s c e l i o n _DOT_ com>
+
+_cpan_name=Test-WWW-Mechanize-CGI
+_cpan_desc='Test CGI applications with Test::WWW::Mechanize'
+_cpan_author=mramberg
+_cpan_version=0.1
+_cpan_md5=55fea6cdaa85433060c3d55a4982272e
+
+pkgrel=1
+pkgname=perl-${_cpan_name,,}
+pkgdesc=$_cpan_desc
+pkgver=$_cpan_version
+md5sums=($_cpan_md5)
+depends=('perl-www-mechanize-cgi' 'perl-test-www-mechanize')
+makedepends=('')
+checkdepends=()
+
+_cpan_path=${_cpan_author:0:1}/${_cpan_author:0:2}/${_cpan_author}
+
+url="http://search.cpan.org/~${_cpan_author}/${_cpan_name}-$pkgver"
+source=("http://search.cpan.org/CPAN/authors/id/${_cpan_path^^}/${_cpan_name}-$pkgver.tar.gz")
+options=(!emptydirs)
+arch=('any')
+
+build() {
+ cd $srcdir/${_cpan_name}-$pkgver
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+ make test
+}
+
+package() {
+ cd $srcdir/${_cpan_name}-$pkgver
+ make install DESTDIR=$pkgdir
+}
+