summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortrizen2015-06-17 18:30:04 +0300
committertrizen2015-06-17 18:30:04 +0300
commit425de30f885e54fae8b78a39f725e3841acc4aa0 (patch)
treefc50bab3373145525cf4a1ec39a76db5c443cbfe
downloadaur-425de30f885e54fae8b78a39f725e3841acc4aa0.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD20
2 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bc077ae242a4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = perl-text-asciitable
+ pkgdesc = Perl/CPAN Module Text::ASCIITable
+ pkgver = 0.20
+ pkgrel = 1
+ url = https://metacpan.org/pod/Text::ASCIITable
+ arch = i686
+ arch = x86_64
+ license = GPL
+ license = Artistic
+ source = http://search.cpan.org/CPAN/authors/id/L/LU/LUNATIC/Text-ASCIITable-0.20.tar.gz
+ sha256sums = 866a1c7dd0150be75e1a4be275858dfc048a165f378ef3845a844526f019a69c
+
+pkgname = perl-text-asciitable
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..23cadbc17234
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Trizen <echo dHJpemVueEBnbWFpbC5jb20K | base64 -d>
+# Contributor: Dimitrije Radojevic <templaryum@gmail.com>
+
+pkgname=perl-text-asciitable
+pkgver=0.20
+pkgrel=1
+_distname="Text-ASCIITable-${pkgver}"
+pkgdesc="Perl/CPAN Module Text::ASCIITable"
+arch=("i686" "x86_64")
+url="https://metacpan.org/pod/Text::ASCIITable"
+license=("GPL" "Artistic")
+source=("http://search.cpan.org/CPAN/authors/id/L/LU/LUNATIC/${_distname}.tar.gz")
+sha256sums=('866a1c7dd0150be75e1a4be275858dfc048a165f378ef3845a844526f019a69c')
+
+package() {
+ cd $_distname
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
+ make || return 1
+ make install DESTDIR="$pkgdir" || return 1
+}