summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn D Jones III2015-06-16 16:07:35 -0600
committerJohn D Jones III2015-06-16 16:07:35 -0600
commit630ffbe00d5883b5b170e623f3aba257b908319a (patch)
tree329d705dc40dd268e527af9e2449cd841ee470f7
downloadaur-630ffbe00d5883b5b170e623f3aba257b908319a.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD50
2 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cd48979efcf5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = perl-text-format
+ pkgdesc = Various subroutines to format text.
+ pkgver = 0.59
+ pkgrel = 1
+ url = https://metacpan.org/release/Text-Format
+ arch = any
+ license = PerlArtistic
+ license = GPL
+ makedepends = perl-module-build
+ depends = perl
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/S/SH/SHLOMIF/Text-Format-0.59.tar.gz
+ md5sums = ab4ae26dbbb7eed101dc7a4324ac9c10
+ sha512sums = 030fc38853f96d64f359af1ad9f776e7c797f564f11207de32477b3b716da665dbce3b91d988241ba1fbd2b884aa85b0ce0b7b473aaf0efd23839f8422a52fcd
+
+pkgname = perl-text-format
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..97c7e86b2df3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Contributor: John D Jones III <jnbek1972 -_AT_- g m a i l -_Dot_- com>
+# Generator : CPANPLUS::Dist::Arch 1.30
+
+pkgname='perl-text-format'
+pkgver='0.59'
+pkgrel='1'
+pkgdesc="Various subroutines to format text."
+arch=('any')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl')
+makedepends=('perl-module-build')
+url='https://metacpan.org/release/Text-Format'
+source=('http://search.cpan.org/CPAN/authors/id/S/SH/SHLOMIF/Text-Format-0.59.tar.gz')
+md5sums=('ab4ae26dbbb7eed101dc7a4324ac9c10')
+sha512sums=('030fc38853f96d64f359af1ad9f776e7c797f564f11207de32477b3b716da665dbce3b91d988241ba1fbd2b884aa85b0ce0b7b473aaf0efd23839f8422a52fcd')
+_distdir="Text-Format-0.59"
+
+build() {
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "$srcdir/$_distdir"
+ /usr/bin/perl Makefile.PL
+ make
+ )
+}
+
+check() {
+ cd "$srcdir/$_distdir"
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+ make test
+ )
+}
+
+package() {
+ cd "$srcdir/$_distdir"
+ make install
+
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
+
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
+# vim:set ts=2 sw=2 et: