summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRubenKelevra2016-07-05 15:41:15 +0200
committerRubenKelevra2016-07-05 15:41:15 +0200
commit15467ab8cfd0e43089a6e2aa8fa972cbde1468f5 (patch)
tree12851d73ca0b36fa42eb56ca0a444b3856ce06d0
downloadaur-15467ab8cfd0e43089a6e2aa8fa972cbde1468f5.tar.gz
initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD46
2 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3929ec229acf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Tue Jul 5 13:40:51 UTC 2016
+pkgbase = perl-text-password-pronounceable
+ pkgdesc = Generate pronounceable passwords
+ pkgver = 0.30
+ pkgrel = 2
+ url = http://search.cpan.org/~tsibley/Text-Password-Pronounceable/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ license = PerlArtistic
+ depends = perl>=5.10.0
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/T/TS/TSIBLEY/Text-Password-Pronounceable-0.30.tar.gz
+ sha256sums = c186a50256e0bedfafb17e7ce157e7c52f19503bb79e18ebf06255911f6ead1a
+
+pkgname = perl-text-password-pronounceable
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1e82e12658fb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Contributor: Maxwell Pray a.k.a. Synthead <synthead@gmail.com>
+# Maintainer: Ruben Kelevra <ruben@vfn-nrw.de>
+
+pkgname=perl-text-password-pronounceable
+_cpanname="Text-Password-Pronounceable"
+pkgver=0.30
+pkgrel=2
+pkgdesc='Generate pronounceable passwords'
+arch=('i686' 'x86_64')
+license=('GPL' 'PerlArtistic')
+url="http://search.cpan.org/~tsibley/$_cpanname/"
+depends=('perl>=5.10.0')
+options=(!emptydirs)
+source=("http://search.cpan.org/CPAN/authors/id/T/TS/TSIBLEY/$_cpanname-$pkgver.tar.gz")
+sha256sums=('c186a50256e0bedfafb17e7ce157e7c52f19503bb79e18ebf06255911f6ead1a')
+
+# Function to change to the working directory and set
+# environment variables to override undesired options.
+prepareEnvironment() {
+ cd "$srcdir/$_cpanname-$pkgver"
+ export \
+ PERL_MM_USE_DEFAULT=1 \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+}
+
+build() {
+ prepareEnvironment
+ /usr/bin/perl Makefile.PL
+ make
+}
+
+check() {
+ prepareEnvironment
+ make test
+}
+
+package() {
+ prepareEnvironment
+ make install
+
+ # Remove "perllocal.pod" and ".packlist".
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}