summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDirk Langer2019-04-12 18:47:19 +0200
committerDirk Langer2019-04-12 18:47:19 +0200
commit1e7b173b1b483c329fb4e904502effc5d8af33e9 (patch)
tree785a178d7192c3bc3003e8e8ebd6dc02d860cd09
downloadaur-1e7b173b1b483c329fb4e904502effc5d8af33e9.tar.gz
initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD53
2 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ee0106886c59
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = perl-text-simpletable-autowidth
+ pkgdesc = Simple eyecandy ASCII tables with auto-width selection
+ pkgver = 0.09
+ pkgrel = 1
+ url = https://metacpan.org/pod/Text::SimpleTable::AutoWidth
+ arch = any
+ license = PerlArtistic
+ license = GPL
+ depends = perl
+ depends = perl-moo
+ depends = perl-text-simpletable
+ options = !emptydirs
+ source = https://cpan.metacpan.org/authors/id/C/CU/CUB/Text-SimpleTable-AutoWidth-0.09.tar.gz
+ md5sums = 2ee9ee49bfcb8a2acd8516dfadb47d0e
+ sha512sums = b35d80ee1040ab744b53d29381034ea7ac67c5a6973516efda67b2ab34412bbadec6397d91a452488dd99158b2a4ee84115f3a52c12cb0e771f77fdc05cfb9ab
+
+pkgname = perl-text-simpletable-autowidth
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..50419362fc6b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Contributor: ordoban <dirk.langer@vvovgonik.de>
+
+pkgname='perl-text-simpletable-autowidth'
+pkgver='0.09'
+pkgrel='1'
+pkgdesc="Simple eyecandy ASCII tables with auto-width selection"
+arch=('any')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+
+depends=(
+ 'perl'
+ 'perl-moo'
+ 'perl-text-simpletable'
+)
+checkdepens=()
+makedepends=()
+url='https://metacpan.org/pod/Text::SimpleTable::AutoWidth'
+source=('https://cpan.metacpan.org/authors/id/C/CU/CUB/Text-SimpleTable-AutoWidth-0.09.tar.gz')
+md5sums=('2ee9ee49bfcb8a2acd8516dfadb47d0e')
+sha512sums=('b35d80ee1040ab744b53d29381034ea7ac67c5a6973516efda67b2ab34412bbadec6397d91a452488dd99158b2a4ee84115f3a52c12cb0e771f77fdc05cfb9ab')
+_distdir="Text-SimpleTable-AutoWidth-0.09"
+
+build() {
+ export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "$srcdir/$_distdir"
+ /usr/bin/perl Makefile.PL
+ make
+}
+
+check() {
+ cd "$srcdir/$_distdir"
+ export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+ make test
+}
+
+package() {
+ cd "$srcdir/$_distdir"
+ make install
+
+ find "$pkgdir" \( -name .packlist -o -name perllocal.pod \) -delete
+}
+
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
+# vim:set ts=2 sw=2 et: