summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHans-Nikolai Viessmann2018-10-24 17:07:12 +0100
committerHans-Nikolai Viessmann2018-10-24 17:07:12 +0100
commit178998f153ee862ee8155e02426bfc5263ae925c (patch)
tree6006ca4dc61808623bb70a1ede145eb78f039cc6
downloadaur-178998f153ee862ee8155e02426bfc5263ae925c.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD34
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..978ffb30f938
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = perl-text-table-csv
+ pkgdesc = This packages the Text-Table-CSV distribution, containing the Text::Table::CSV module
+ pkgver = 0.020
+ pkgrel = 1
+ url = https://metacpan.org/release/Text-Table-CSV
+ arch = any
+ license = GPL
+ license = PerlArtistic
+ depends = perl
+ options = !emptydirs
+ options = purge
+ source = http://search.cpan.org/CPAN/authors/id/P/PE/PERLANCAR/Text-Table-CSV-0.020.tar.gz
+ md5sums = 3fa64cf810eb73fde18abcfdbb7618f5
+
+pkgname = perl-text-table-csv
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f443d16136f7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Contributor: Hans-Nikolai Viessmann <hans AT viess DOT mn>
+pkgname=perl-text-table-csv
+pkgver=0.020
+pkgrel=1
+pkgdesc='This packages the Text-Table-CSV distribution, containing the Text::Table::CSV module'
+_dist=Text-Table-CSV
+arch=('any')
+url="https://metacpan.org/release/$_dist"
+license=('GPL' 'PerlArtistic')
+depends=(perl)
+options=('!emptydirs' purge)
+source=("http://search.cpan.org/CPAN/authors/id/P/PE/PERLANCAR/$_dist-$pkgver.tar.gz")
+md5sums=('3fa64cf810eb73fde18abcfdbb7618f5')
+
+build() {
+ cd "$srcdir/$_dist-$pkgver"
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps
+ /usr/bin/perl Makefile.PL
+ make
+}
+
+check() {
+ cd "$srcdir/$_dist-$pkgver"
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1
+ make test
+}
+
+package() {
+ cd "$srcdir/$_dist-$pkgver"
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ make install INSTALLDIRS=vendor DESTDIR="$pkgdir"
+}