summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn D Jones III2015-06-16 16:10:00 -0600
committerJohn D Jones III2015-06-16 16:10:00 -0600
commitc60ab3700ac8d89a1a77f85748403260547339c1 (patch)
tree1a888c577312d16f89f1c5d5a2d6053410134db1
downloadaur-perl-text-xsv.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD50
2 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e722a82c0460
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = perl-text-xsv
+ pkgdesc = read character separated files
+ pkgver = 0.21
+ pkgrel = 1
+ url = http://search.cpan.org/dist/Text-xSV
+ arch = any
+ license = PerlArtistic
+ license = GPL
+ depends = perl
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/T/TI/TILLY/Text-xSV-0.21.tar.gz
+ md5sums = 293eea793ce885f3b5c84b98364d29b3
+ sha512sums = f04d83477805f6f43654d6ca15ee16c7bc213895b05cce4e784432c8ada070fe22de2e34464c2de5ce8ce3fb9c155ad1aaa1b9f19a032c49935fe9dd1eca25bb
+
+pkgname = perl-text-xsv
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9affb0239176
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Contributor: John D Jones III <j[nospace]n[nospace]b[nospace]e[nospace]k[nospace]1972 -_AT_- the domain name google offers a mail service at ending in dot com>
+# Generator : CPANPLUS::Dist::Arch 1.25
+
+pkgname='perl-text-xsv'
+pkgver='0.21'
+pkgrel='1'
+pkgdesc="read character separated files"
+arch=('any')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl')
+makedepends=()
+url='http://search.cpan.org/dist/Text-xSV'
+source=('http://search.cpan.org/CPAN/authors/id/T/TI/TILLY/Text-xSV-0.21.tar.gz')
+md5sums=('293eea793ce885f3b5c84b98364d29b3')
+sha512sums=('f04d83477805f6f43654d6ca15ee16c7bc213895b05cce4e784432c8ada070fe22de2e34464c2de5ce8ce3fb9c155ad1aaa1b9f19a032c49935fe9dd1eca25bb')
+_distdir="Text-xSV-0.21"
+
+build() {
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "$srcdir/$_distdir"
+ /usr/bin/perl Makefile.PL
+ make
+ )
+}
+
+check() {
+ cd "$srcdir/$_distdir"
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+ make test
+ )
+}
+
+package() {
+ cd "$srcdir/$_distdir"
+ make install
+
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
+
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
+# vim:set ts=2 sw=2 et: