summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfelics@felics-tablet2017-08-01 14:40:54 +0200
committerfelics@felics-tablet2017-08-01 14:40:54 +0200
commitcde55ff4af8146c5900c936af5edf70ad476f67b (patch)
tree971f08d9229d0b36c25bbb9df2b84223deee7137
downloadaur-cde55ff4af8146c5900c936af5edf70ad476f67b.tar.gz
Initial commit.
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD58
2 files changed, 85 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..77f9799e021b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = perl-travel-routing-de-vrr-git
+ pkgdesc = Unofficial efa.vrr.de command line client and Perl module
+ pkgver = 2.16+gdb888ca
+ pkgrel = 1
+ url = http://finalrewind.org/projects/Travel-Routing-DE-VRR/
+ arch = any
+ license = custom:WTFPL
+ makedepends = perl-module-build
+ makedepends = perl-file-slurp
+ makedepends = perl-test-compile
+ makedepends = perl-test-fatal
+ makedepends = perl-test-pod
+ depends = perl-class-accessor
+ depends = perl-exception-class
+ depends = perl-libwww
+ depends = perl-xml-libxml
+ provides = perl-travel-routing-de-vrr=2.16+gdb888ca
+ conflicts = perl-travel-routing-de-vrr
+ replaces = perl-travel-routing-de-vrr<=2.16+gdb888ca
+ options = !emptydirs
+ source = Travel-Routing-DE-VRR::git+http://git.finalrewind.org/Travel-Routing-DE-VRR
+ source = http://www.wtfpl.net/txt/copying/COPYING
+ sha256sums = SKIP
+ sha256sums = 0356258391e190dc1d44ea01565cfe627fe44e27dad693a0a54c2483a7b223e5
+
+pkgname = perl-travel-routing-de-vrr-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..644a1def0e87
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,58 @@
+# Maintainer: dreieck
+# Contributor: Jens Adam <jra@byte.cx>
+
+_perlmod=Travel-Routing-DE-VRR
+_pkgname=perl-travel-routing-de-vrr
+pkgname="${_pkgname}-git"
+_pkgver='latest'
+pkgver=2.16+gdb888ca
+pkgrel=1
+pkgdesc='Unofficial efa.vrr.de command line client and Perl module'
+url='http://finalrewind.org/projects/Travel-Routing-DE-VRR/'
+license=('custom:WTFPL')
+arch=('any')
+depends=('perl-class-accessor' 'perl-exception-class' 'perl-libwww' 'perl-xml-libxml')
+makedepends=('perl-module-build' 'perl-file-slurp' 'perl-test-compile' 'perl-test-fatal' 'perl-test-pod')
+provides=("${_pkgname}=${pkgver}")
+replaces=("${_pkgname}<=${pkgver}")
+conflicts=("${_pkgname}")
+options=('!emptydirs')
+# source=("http://finalrewind.org/projects/${_perlmod}/${_perlmod}-${pkgver}.tar.gz"{,.asc}
+# 'http://www.wtfpl.net/txt/copying/COPYING')
+source=(
+ "${_perlmod}::git+http://git.finalrewind.org/${_perlmod}"
+ 'http://www.wtfpl.net/txt/copying/COPYING'
+)
+sha256sums=(
+ 'SKIP'
+ '0356258391e190dc1d44ea01565cfe627fe44e27dad693a0a54c2483a7b223e5'
+)
+
+pkgver() {
+ cd "${srcdir}/${_perlmod}"
+ _descr="$(git describe --tags --long)"
+ _ver="$(echo "${_descr}" | awk -F '-' '{print $1}')"
+ _rev="$(echo "${_descr}" | awk -F '-' '{print $3}')"
+ echo "${_ver}+${_rev}"
+}
+
+build() {
+ cd "${srcdir}/${_perlmod}"
+ perl Build.PL installdirs=vendor destdir="${pkgdir}"
+ ./Build
+}
+
+check() {
+ cd "${srcdir}/${_perlmod}"
+ ./Build test
+}
+
+package() {
+ cd "${srcdir}/${_perlmod}"
+ ./Build install
+ install -D -v -m644 "${srcdir}/COPYING" "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
+ install -D -v -m644 provides/zsh/completions/_efa "${pkgdir}/usr/share/zsh/site-functions/_efa"
+ install -D -v -m644 README "${pkgdir}/usr/share/doc/${_pkgname}/README"
+ install -D -v -m644 Changelog "${pkgdir}/usr/share/doc/${_pkgname}/Changelog"
+
+}