summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArch Nous2015-09-01 17:16:29 +0300
committerArch Nous2015-09-01 17:16:29 +0300
commitc3db2acc51b170c0d1598e530aa68b5ab549106b (patch)
tree3bfaf1113103f4d0025d3cffc97b92300cefd660
downloadaur-c3db2acc51b170c0d1598e530aa68b5ab549106b.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD50
2 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..479733b0a981
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = perl-types-path-tiny
+ pkgdesc = Path::Tiny types and coercions for Moose and Moo
+ pkgver = 0.005
+ pkgrel = 1
+ url = https://metacpan.org/release/Types-Path-Tiny
+ arch = any
+ license = PerlArtistic
+ license = GPL
+ depends = perl-file-pushd>=0
+ depends = perl-path-tiny>=0
+ depends = perl-type-tiny>=0
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/D/DA/DAGOLDEN/Types-Path-Tiny-0.005.tar.gz
+ md5sums = 94945f7f1a3be576c78bce82bfc89fa0
+ sha512sums = 2e9f4694950bc9426d7b72e33234e594f4c2d4cc434526e3096b7a193cebdb2b4c4890b01637a1684e1d3ca67e355879bce5b79dcc69d14ff23f591ff193623e
+
+pkgname = perl-types-path-tiny
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..92fa262c7625
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Contributor: Christos Nouskas <nous@archlinux.us>
+# Generator : CPANPLUS::Dist::Arch 1.30
+
+pkgname='perl-types-path-tiny'
+pkgver='0.005'
+pkgrel='1'
+pkgdesc="Path::Tiny types and coercions for Moose and Moo"
+arch=('any')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl-file-pushd>=0' 'perl-path-tiny>=0' 'perl-type-tiny>=0')
+makedepends=()
+url='https://metacpan.org/release/Types-Path-Tiny'
+source=('http://search.cpan.org/CPAN/authors/id/D/DA/DAGOLDEN/Types-Path-Tiny-0.005.tar.gz')
+md5sums=('94945f7f1a3be576c78bce82bfc89fa0')
+sha512sums=('2e9f4694950bc9426d7b72e33234e594f4c2d4cc434526e3096b7a193cebdb2b4c4890b01637a1684e1d3ca67e355879bce5b79dcc69d14ff23f591ff193623e')
+_distdir="Types-Path-Tiny-0.005"
+
+build() {
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "$srcdir/$_distdir"
+ /usr/bin/perl Makefile.PL
+ make
+ )
+}
+
+check() {
+ cd "$srcdir/$_distdir"
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+ make test
+ )
+}
+
+package() {
+ cd "$srcdir/$_distdir"
+ make install
+
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
+
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
+# vim:set ts=2 sw=2 et: