summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn D Jones III2015-06-16 16:13:09 -0600
committerJohn D Jones III2015-06-16 16:13:09 -0600
commit6674427f3eaf09415fb4f4d6ed392a1cce159803 (patch)
treef349eb06fed77e28473f1128de319b6baffad93c
downloadaur-6674427f3eaf09415fb4f4d6ed392a1cce159803.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD50
2 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1ea4611be8da
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = perl-uri-encode
+ pkgdesc = Simple percent Encoding/Decoding
+ pkgver = 0.09
+ pkgrel = 1
+ url = http://search.cpan.org/dist/URI-Encode
+ arch = any
+ license = PerlArtistic
+ license = GPL
+ depends = perl
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/M/MI/MITHUN/URI-Encode-0.09.tar.gz
+ md5sums = 369d5dd49215f3f591a1e5975609df27
+ sha512sums = feea17dffa82c5c89b427cdad7805794e9fc483a01f473fe1680a0559e2bc08393ba5427c7734860dc21b7d125f724f864112cf15e3db11238046147ab01aaec
+
+pkgname = perl-uri-encode
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7e9f095b8bd0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Contributor: John D Jones III <j[nospace]n[nospace]b[nospace]e[nospace]k[nospace]1972 -_AT_- the domain name google offers a mail service at ending in dot com>
+# Generator : CPANPLUS::Dist::Arch 1.25
+
+pkgname='perl-uri-encode'
+pkgver='0.09'
+pkgrel='1'
+pkgdesc="Simple percent Encoding/Decoding"
+arch=('any')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl')
+makedepends=()
+url='http://search.cpan.org/dist/URI-Encode'
+source=('http://search.cpan.org/CPAN/authors/id/M/MI/MITHUN/URI-Encode-0.09.tar.gz')
+md5sums=('369d5dd49215f3f591a1e5975609df27')
+sha512sums=('feea17dffa82c5c89b427cdad7805794e9fc483a01f473fe1680a0559e2bc08393ba5427c7734860dc21b7d125f724f864112cf15e3db11238046147ab01aaec')
+_distdir="URI-Encode-0.09"
+
+build() {
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "$srcdir/$_distdir"
+ /usr/bin/perl Makefile.PL
+ make
+ )
+}
+
+check() {
+ cd "$srcdir/$_distdir"
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+ make test
+ )
+}
+
+package() {
+ cd "$srcdir/$_distdir"
+ make install
+
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
+
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
+# vim:set ts=2 sw=2 et: