summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn D Jones III2015-06-16 16:14:20 -0600
committerJohn D Jones III2015-06-16 16:14:20 -0600
commit146be694b20d95e8218906d6b21ec0bd1eb4b5c2 (patch)
tree6bd8a89195da41a10fdf531ab8ddb7b3e2526f9b
downloadaur-146be694b20d95e8218906d6b21ec0bd1eb4b5c2.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD50
2 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7594aeea1d5a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = perl-validate-tiny
+ pkgdesc = Minimalistic data validation
+ pkgver = 0.984
+ pkgrel = 1
+ url = http://search.cpan.org/dist/Validate-Tiny
+ arch = any
+ license = PerlArtistic
+ license = GPL
+ depends = perl-list-moreutils
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/M/MI/MINIMAL/Validate-Tiny-0.984.tar.gz
+ md5sums = 363d1de0023cc6db962ebc2e49d16538
+ sha512sums = 4eca7035316468e99ed02c97a2b2b8801a94f18db46fa535c2b0267b8fb5d780091357448f6b7b63161cff8c537e2d41c49aff3176a4c0d88db4fa0a55a54b2f
+
+pkgname = perl-validate-tiny
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ba1d4aec2fc2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Contributor: John D Jones III <j[nospace]n[nospace]b[nospace]e[nospace]k[nospace]1972 -_AT_- the domain name google offers a mail service at ending in dot com>
+# Generator : CPANPLUS::Dist::Arch 1.25
+
+pkgname='perl-validate-tiny'
+pkgver='0.984'
+pkgrel='1'
+pkgdesc="Minimalistic data validation"
+arch=('any')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl-list-moreutils')
+makedepends=()
+url='http://search.cpan.org/dist/Validate-Tiny'
+source=('http://search.cpan.org/CPAN/authors/id/M/MI/MINIMAL/Validate-Tiny-0.984.tar.gz')
+md5sums=('363d1de0023cc6db962ebc2e49d16538')
+sha512sums=('4eca7035316468e99ed02c97a2b2b8801a94f18db46fa535c2b0267b8fb5d780091357448f6b7b63161cff8c537e2d41c49aff3176a4c0d88db4fa0a55a54b2f')
+_distdir="Validate-Tiny-0.984"
+
+build() {
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "$srcdir/$_distdir"
+ /usr/bin/perl Makefile.PL
+ make
+ )
+}
+
+check() {
+ cd "$srcdir/$_distdir"
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+ make test
+ )
+}
+
+package() {
+ cd "$srcdir/$_distdir"
+ make install
+
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
+
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
+# vim:set ts=2 sw=2 et: