summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Rogoża2017-02-14 23:00:46 +0100
committerPiotr Rogoża2017-02-14 23:00:46 +0100
commit4822b3a2e8ebf4af7fb1cc9fc83f305d83ca472f (patch)
tree951b08ea7f82d6c2f65c5baf18f28f50fb1ce994
downloadaur-4822b3a2e8ebf4af7fb1cc9fc83f305d83ca472f.tar.gz
Initial commit for perl-vcg-0.5
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD47
2 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..04359e52303e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Tue Feb 14 21:59:09 UTC 2017
+pkgbase = perl-vcg
+ pkgdesc = Interface to the VCG graphing tool
+ pkgver = 0.5
+ pkgrel = 1
+ url = http://search.cpan.org/dist/VCG/
+ arch = any
+ license = GPL
+ license = PerlArtistic
+ makedepends = perl-ipc-run
+ depends = perl
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/T/TE/TEEJAY/VCG-0.5.tar.gz
+ sha256sums = c5095c203744e2b73ba15e24a3a4daef9a5c08f0ef92dcdaf80e9c961f1082bf
+
+pkgname = perl-vcg
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5e9521abf4eb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+pkgname=perl-vcg
+pkgver=0.5
+pkgrel=1
+_author="T/TE/TEEJAY"
+_perlmod="VCG"
+pkgdesc="Interface to the VCG graphing tool"
+arch=('any')
+url="http://search.cpan.org/dist/VCG/"
+license=('GPL' 'PerlArtistic')
+depends=(perl)
+makedepends=(perl-ipc-run)
+options=(!emptydirs)
+source=("http://search.cpan.org/CPAN/authors/id/$_author/$_perlmod-$pkgver.tar.gz")
+sha256sums=('c5095c203744e2b73ba15e24a3a4daef9a5c08f0ef92dcdaf80e9c961f1082bf')
+prepare(){
+ unset PERL5LIB PERL_MM_OPT PERL_MB_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps MODULEBUILDRC=/dev/null
+}
+build(){
+ cd "$srcdir"/$_perlmod-$pkgver
+
+ if [ -f Makefile.PL ]; then
+ /usr/bin/perl Makefile.PL
+ make
+ else
+ /usr/bin/perl Build.PL
+ ./Build
+ fi
+}
+check(){
+ cd "$srcdir"/$_perlmod-$pkgver
+
+ if [ -f Makefile.PL ]; then
+ make test
+ else
+ ./Build test
+ fi
+}
+package(){
+ cd "$srcdir"/$_perlmod-$pkgver
+
+ if [ -f Makefile.PL ]; then
+ make install INSTALLDIRS=vendor DESTDIR="$pkgdir"
+ else
+ ./Build install installdirs=vendor destdir="$pkgdir"
+ fi
+}