summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Rogoża2015-10-03 23:43:19 +0200
committerPiotr Rogoża2015-10-03 23:43:19 +0200
commit27a87651f5d323eab5b789f9f26714517b898e93 (patch)
treea05256247907823c33b4ce3831acda2d056bf5de
downloadaur-27a87651f5d323eab5b789f9f26714517b898e93.tar.gz
Initial commit, version 0.05
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD61
2 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..24cbe926e7f9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = perl-video-subtitle-srt
+ pkgdesc = Video-Subtitle-SRT - manipulate SRT subtitle files
+ pkgver = 0.05
+ pkgrel = 1
+ url = http://search.cpan.org/dist/Video-Subtitle-SRT/
+ arch = any
+ license = GPL
+ license = PerlArtistic
+ depends = perl
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/b/bk/bkb/Video-Subtitle-SRT-0.05.tar.gz
+
+pkgname = perl-video-subtitle-srt
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0a04d649f25f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,61 @@
+# Maintainer: Piotr Rogoza <piotr dot r dot public at gmail dot com>
+# Contributor: Piotr Rogoza <piotr dot r dot public at gmail dot com>
+
+pkgname=perl-video-subtitle-srt
+pkgver=0.05
+pkgrel=1
+_author="B/BK/BKB"
+_perlmod="Video-Subtitle-SRT"
+pkgdesc="Video-Subtitle-SRT - manipulate SRT subtitle files"
+arch=('any')
+url="http://search.cpan.org/dist/Video-Subtitle-SRT/"
+license=('GPL' 'PerlArtistic')
+depends=(perl)
+options=(!emptydirs)
+source=("http://search.cpan.org/CPAN/authors/id/$_author/$_perlmod-$pkgver.tar.gz")
+sha256sums=('e9f94229b28ed4f5a90ea614eeb66b5b6abcb945269e5fcd7b6b6026eb055306')
+
+build(){
+ cd "$srcdir"/$_perlmod-$pkgver
+
+ # Setting these env variables overwrites any command-line-options we don't want...
+ export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ # If using Makefile.PL
+ if [ -r Makefile.PL ]; then
+ /usr/bin/perl Makefile.PL
+ make
+ # If using Build.PL
+ elif [ -r Build.PL ]; then
+ /usr/bin/perl Build.PL
+ perl Build
+ fi
+}
+check(){
+ cd "$srcdir"/$_perlmod-$pkgver
+
+ # If using Makefile.PL
+ if [ -r Makefile.PL ]; then
+ make test
+ # If using Build.PL
+ elif [ -r Build.PL ]; then
+ perl Build test
+ fi
+}
+package(){
+ cd "$srcdir"/$_perlmod-$pkgver
+
+ # If using Makefile.PL
+ if [ -r Makefile.PL ]; then
+ make install
+ # If using Build.PL
+ elif [ -r Build.PL ]; then
+ perl Build install
+ fi
+
+ # remove perllocal.pod and .packlist
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}