summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn D Jones III2015-09-16 11:31:58 -0600
committerJohn D Jones III2015-09-16 11:31:58 -0600
commitbe3b9fad57218e13e1ef5489b19fc149553905ae (patch)
tree90e1720af1d4b4122be768c90cdd1aec2a60789a
downloadaur-be3b9fad57218e13e1ef5489b19fc149553905ae.tar.gz
Update to 0.26
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD50
2 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6de1880bbebb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = perl-want
+ pkgdesc = A generalisation of wantarray
+ pkgver = 0.26
+ pkgrel = 1
+ url = https://metacpan.org/release/Want
+ arch = i686
+ arch = x86_64
+ license = PerlArtistic
+ license = GPL
+ depends = perl
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/R/RO/ROBIN/Want-0.26.tar.gz
+ md5sums = 3f63f10da1d5407d72a64ef62b5e6264
+ sha512sums = 4b10d483068f0ab976c247b416477fe42903e06abf46678d5c5cb2308732b69038761b7aaefe42e232d666c3032e6cf303c11918f10dde1572bf25aa3ae1e8bd
+
+pkgname = perl-want
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ba58a2e48f94
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Contributor: John D Jones III AKA jnbek <jnbek1972 -_AT_- g m a i l -_Dot_- com>
+# Generator : CPANPLUS::Dist::Arch 1.30
+
+pkgname='perl-want'
+pkgver='0.26'
+pkgrel='1'
+pkgdesc="A generalisation of wantarray"
+arch=('i686' 'x86_64')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl')
+makedepends=()
+url='https://metacpan.org/release/Want'
+source=('http://search.cpan.org/CPAN/authors/id/R/RO/ROBIN/Want-0.26.tar.gz')
+md5sums=('3f63f10da1d5407d72a64ef62b5e6264')
+sha512sums=('4b10d483068f0ab976c247b416477fe42903e06abf46678d5c5cb2308732b69038761b7aaefe42e232d666c3032e6cf303c11918f10dde1572bf25aa3ae1e8bd')
+_distdir="Want-0.26"
+
+build() {
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "$srcdir/$_distdir"
+ /usr/bin/perl Makefile.PL
+ make
+ )
+}
+
+check() {
+ cd "$srcdir/$_distdir"
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+ make test
+ )
+}
+
+package() {
+ cd "$srcdir/$_distdir"
+ make install
+
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
+
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
+# vim:set ts=2 sw=2 et: