summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn D Jones III2015-06-16 16:15:18 -0600
committerJohn D Jones III2015-06-16 16:15:18 -0600
commit1fb02d9c1e9b832db03cea33ad3e71a7c0e6905a (patch)
tree3f1aa761e99b92b82d0a7a69d3f1657697743683
downloadaur-1fb02d9c1e9b832db03cea33ad3e71a7c0e6905a.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD50
2 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e56cb0bfd6c4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = perl-warnings-illegalproto
+ pkgdesc = Disable illegal prototype warnings on old Perls
+ pkgver = 0.001003
+ pkgrel = 1
+ url = http://search.mcpan.org/dist/warnings-illegalproto
+ arch = any
+ license = PerlArtistic
+ license = GPL
+ depends = perl-strictures
+ options = !emptydirs
+ source = http://search.mcpan.org/CPAN/authors/id/F/FR/FREW/warnings-illegalproto-0.001003.tar.gz
+ md5sums = 47c885bd792b7fc30f86255fdad6e27c
+ sha512sums = f3bf840074c991165e3475d4d797d39b3f2e4b82bb1b9780756ecdfc7b250d297bd87153e31176a73c0310db2ec3bdc5def4797a1f55aa333a806d8ab8414bec
+
+pkgname = perl-warnings-illegalproto
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5e378f66a1d7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Contributor: John D Jones III <jnbek1972 -_AT_- g m a i l -_Dot_- com>
+# Generator : CPANPLUS::Dist::Arch 1.29
+
+pkgname='perl-warnings-illegalproto'
+pkgver='0.001003'
+pkgrel='1'
+pkgdesc="Disable illegal prototype warnings on old Perls"
+arch=('any')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl-strictures')
+makedepends=()
+url='http://search.mcpan.org/dist/warnings-illegalproto'
+source=('http://search.mcpan.org/CPAN/authors/id/F/FR/FREW/warnings-illegalproto-0.001003.tar.gz')
+md5sums=('47c885bd792b7fc30f86255fdad6e27c')
+sha512sums=('f3bf840074c991165e3475d4d797d39b3f2e4b82bb1b9780756ecdfc7b250d297bd87153e31176a73c0310db2ec3bdc5def4797a1f55aa333a806d8ab8414bec')
+_distdir="warnings-illegalproto-0.001003"
+
+build() {
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "$srcdir/$_distdir"
+ /usr/bin/perl Makefile.PL
+ make
+ )
+}
+
+check() {
+ cd "$srcdir/$_distdir"
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+ make test
+ )
+}
+
+package() {
+ cd "$srcdir/$_distdir"
+ make install
+
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
+
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
+# vim:set ts=2 sw=2 et: