summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnton Leontiev2013-11-10 20:58:49 +0400
committerAnton Leontiev2015-02-15 07:48:19 +0300
commit78f684dff98b2b7b24a179b24e8e1ee1f20562fb (patch)
tree39de5ee3998183515b7d85f029a6bbe9719f46fd
downloadaur-78f684dff98b2b7b24a179b24e8e1ee1f20562fb.tar.gz
Initial v0.1.4
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD35
-rw-r--r--PKGBUILD.tt35
4 files changed, 94 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..52e552934ba1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = perl-www-expand
+ pkgdesc = Perl module to expand any shortened URL
+ pkgver = 0.1.4
+ pkgrel = 1
+ url = http://search.cpan.org/dist/WWW-Expand
+ arch = any
+ license = PerlArtistic
+ license = GPL
+ depends = perl>=5.8.8
+ depends = perl-http-message
+ depends = perl-libwww
+ depends = perl-strictures
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/G/GL/GLITCHMR/WWW-Expand-0.1.4.tar.gz
+ md5sums = 9bbd23792c04aa655b90309fb819f508
+
+pkgname = perl-www-expand
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e6b6b4b8077d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+*.tar.gz
+*.tar.bz2
+*.tar.xz
+*.tar.lz
+src/
+pkg/ \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..050456e08166
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# CPAN Name : WWW::Expand
+# Contributor: Anton Leontiev <bunder /at/ t-25.ru>
+# Generator : CPANPLUS::Dist::Arch 1.28
+
+pkgname=perl-www-expand
+pkgver=0.1.4
+pkgrel=1
+pkgdesc='Perl module to expand any shortened URL'
+arch=('any')
+url='http://search.cpan.org/dist/WWW-Expand'
+license=('PerlArtistic' 'GPL')
+depends=('perl>=5.8.8'
+ 'perl-http-message'
+ 'perl-libwww'
+ 'perl-strictures')
+source=(http://search.cpan.org/CPAN/authors/id/G/GL/GLITCHMR/WWW-Expand-0.1.4.tar.gz)
+options=(!emptydirs)
+md5sums=('9bbd23792c04aa655b90309fb819f508')
+
+build() {
+ cd WWW-Expand-0.1.4
+ PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL="--skipdeps" perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ cd WWW-Expand-0.1.4
+ make test
+}
+
+package() {
+ cd WWW-Expand-0.1.4
+ make install DESTDIR="$pkgdir"
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
diff --git a/PKGBUILD.tt b/PKGBUILD.tt
new file mode 100644
index 000000000000..c2fc5ce5a8b4
--- /dev/null
+++ b/PKGBUILD.tt
@@ -0,0 +1,35 @@
+# CPAN Name : WWW::Expand
+# Contributor: [% packager %]
+# Generator : CPANPLUS::Dist::Arch [% version %]
+
+pkgname=[% pkgname %]
+pkgver=[% pkgver %]
+pkgrel=[% pkgrel %]
+pkgdesc='Perl module to expand any shortened URL'
+arch=('any')
+url='[% url %]'
+license=('PerlArtistic' 'GPL')
+depends=('perl>=5.8.8'
+ 'perl-http-message'
+ 'perl-libwww'
+ 'perl-strictures')
+source=([% source %])
+options=(!emptydirs)
+md5sums=('[% md5sums %]')
+
+build() {
+ cd [% distdir %]
+ PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL="--skipdeps" perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ cd [% distdir %]
+ make test
+}
+
+package() {
+ cd [% distdir %]
+ make install DESTDIR="$pkgdir"
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}