summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWu Zhenyu2023-03-11 00:10:00 +0800
committerWu Zhenyu2023-03-11 00:10:00 +0800
commit9414bbb72563599a3013c54ced340cce2e1c5df3 (patch)
tree4a6171f066914d90e333afe8e9e844d0b0949851
downloadaur-9414bbb72563599a3013c54ced340cce2e1c5df3.tar.gz
:tada: Initial
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD49
3 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..44bf637ed7ad
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by makepkg 6.0.2
+# Fri Mar 10 16:08:21 UTC 2023
+pkgbase = perl-www-pastebin-pastebincom-create
+ pkgdesc = paste on www.pastebin.com without API keys
+ pkgver = 1.003
+ pkgrel = 1
+ url = https://metacpan.org/release/WWW-Pastebin-PastebinCom-Create
+ arch = any
+ license = PerlArtistic
+ license = GPL
+ depends = perl-moo>=1.004001
+ depends = perl-www-mechanize>=1.73
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/Z/ZO/ZOFFIX/WWW-Pastebin-PastebinCom-Create-1.003.tar.gz
+ md5sums = 9c8fec1d38e0afe3dbdf7d0d843a5796
+ sha512sums = 6388477145578fbe0478463884fe5cb3240c153e486dda48e9e54ead47d2ef75b22e65476241a9e834c66609427bed53d0c269b62d8575ac4af3eba6f8b93fe9
+
+pkgname = perl-www-pastebin-pastebincom-create
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..8a5cafba2b8e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+/*
+!/.gitignore
+!/PKGBUILD
+!/.SRCINFO
+!/*.install
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..173a5f89b6c6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Contributor: Anonymous
+# Generator : CPANPLUS::Dist::Arch 1.32
+
+pkgname='perl-www-pastebin-pastebincom-create'
+pkgver='1.003'
+pkgrel='1'
+pkgdesc="paste on www.pastebin.com without API keys"
+arch=('any')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl-moo>=1.004001' 'perl-www-mechanize>=1.73')
+makedepends=()
+url='https://metacpan.org/release/WWW-Pastebin-PastebinCom-Create'
+source=('http://search.cpan.org/CPAN/authors/id/Z/ZO/ZOFFIX/WWW-Pastebin-PastebinCom-Create-1.003.tar.gz')
+md5sums=('9c8fec1d38e0afe3dbdf7d0d843a5796')
+sha512sums=('6388477145578fbe0478463884fe5cb3240c153e486dda48e9e54ead47d2ef75b22e65476241a9e834c66609427bed53d0c269b62d8575ac4af3eba6f8b93fe9')
+_distdir="WWW-Pastebin-PastebinCom-Create-1.003"
+
+build() {
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "$srcdir/$_distdir"
+ /usr/bin/perl Makefile.PL
+ make
+ )
+}
+
+# check() {
+# cd "$srcdir/$_distdir"
+# ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+# make test
+# )
+# }
+
+package() {
+ cd "$srcdir/$_distdir"
+ make install
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
+
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
+# vim:set ts=2 sw=2 et: