summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnton Leontiev2013-08-23 16:58:29 +0400
committerAnton Leontiev2015-02-15 07:48:01 +0300
commit58a56bdb84b53a31c232ac41b79d174d1921407f (patch)
tree688394bf646dd0a2daf454fdf4125cce65400a2c
downloadaur-58a56bdb84b53a31c232ac41b79d174d1921407f.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD33
-rw-r--r--PKGBUILD.tt33
4 files changed, 89 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..23d39e561c15
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = perl-www-shorten
+ pkgdesc = Interface to URL shortening sites
+ pkgver = 3.03
+ pkgrel = 1
+ url = http://search.cpan.org/dist/WWW-Shorten
+ arch = any
+ license = PerlArtistic
+ license = GPL
+ depends = perl
+ depends = perl-libwww
+ optdepends = perl-config-auto: for configuration file support
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/D/DA/DAVECROSS/WWW-Shorten-3.03.tar.gz
+ md5sums = 8ba21ec85951c5ed7f87e2ea28280882
+
+pkgname = perl-www-shorten
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e6b6b4b8077d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+*.tar.gz
+*.tar.bz2
+*.tar.xz
+*.tar.lz
+src/
+pkg/ \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..776008569351
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# CPAN Name : WWW::Shorten
+# Contributor: Anton Leontiev <bunder /at/ t-25.ru>
+# Generator : CPANPLUS::Dist::Arch 1.23
+
+pkgname=perl-www-shorten
+pkgver=3.03
+pkgrel=1
+pkgdesc='Interface to URL shortening sites'
+arch=('any')
+url='http://search.cpan.org/dist/WWW-Shorten'
+license=('PerlArtistic' 'GPL')
+depends=('perl' 'perl-libwww')
+optdepends=("perl-config-auto: for configuration file support")
+source=(http://search.cpan.org/CPAN/authors/id/D/DA/DAVECROSS/WWW-Shorten-3.03.tar.gz)
+options=(!emptydirs)
+md5sums=("8ba21ec85951c5ed7f87e2ea28280882")
+
+build() {
+ cd "$srcdir/WWW-Shorten-3.03"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ cd "$srcdir/WWW-Shorten-3.03"
+ make test
+}
+
+package() {
+ cd "$srcdir/WWW-Shorten-3.03"
+ make install DESTDIR="$pkgdir"
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
diff --git a/PKGBUILD.tt b/PKGBUILD.tt
new file mode 100644
index 000000000000..7360d4cc3dad
--- /dev/null
+++ b/PKGBUILD.tt
@@ -0,0 +1,33 @@
+# CPAN Name : WWW::Shorten
+# Contributor: [% packager %]
+# Generator : CPANPLUS::Dist::Arch [% version %]
+
+pkgname=[% pkgname %]
+pkgver=[% pkgver %]
+pkgrel=[% pkgrel %]
+pkgdesc='Interface to URL shortening sites'
+arch=('any')
+url='[% url %]'
+license=('PerlArtistic' 'GPL')
+depends=('perl' 'perl-libwww')
+optdepends=("perl-config-auto: for configuration file support")
+source=([% source %])
+options=(!emptydirs)
+md5sums=("[% md5sums %]")
+
+build() {
+ cd "$srcdir/[% distdir %]"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ cd "$srcdir/[% distdir %]"
+ make test
+}
+
+package() {
+ cd "$srcdir/[% distdir %]"
+ make install DESTDIR="$pkgdir"
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}