summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnton Leontiev2020-03-14 16:50:41 +0300
committerAnton Leontiev2020-03-14 16:50:41 +0300
commita6f2dcbabad68acb94c5b127228f4b0cf15a8f47 (patch)
treed186a9b22e6b949a933cdb8022a4edce0842bf42
parentdd4cb3f6a379d3077184464a3b99eca5e7e4733f (diff)
downloadaur-a6f2dcbabad68acb94c5b127228f4b0cf15a8f47.tar.gz
Update to v3.093
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD18
-rw-r--r--PKGBUILD.tt2
3 files changed, 14 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 71eb0e73bab6..45356a3e6da6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
pkgbase = perl-www-shorten
pkgdesc = Interface to URL shortening sites
- pkgver = 3.06
+ pkgver = 3.093
pkgrel = 1
url = https://metacpan.org/release/WWW-Shorten
arch = any
license = PerlArtistic
license = GPL
- depends = perl
depends = perl-libwww
+ depends = perl-try-tiny
optdepends = perl-config-auto: for configuration file support
options = !emptydirs
- source = http://search.cpan.org/CPAN/authors/id/D/DA/DAVECROSS/WWW-Shorten-3.06.tar.gz
- md5sums = 7fec4441d031973710ee61999f964bd2
+ source = http://search.cpan.org/CPAN/authors/id/C/CA/CAPOEIRAB/WWW-Shorten-3.093.tar.gz
+ md5sums = 44bfbdd42ed459bf1e87291202ed35cf
pkgname = perl-www-shorten
diff --git a/PKGBUILD b/PKGBUILD
index 9ca416f53a32..7871d0c35d28 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,19 @@
# CPAN Name : WWW::Shorten
-# Contributor: Anton Leontiev <bunder /at/ t-25.ru>
-# Generator : CPANPLUS::Dist::Arch 1.30
+# Contributor: Anton Leontiev <scileont /at/ gmail.com>
+# Generator : CPANPLUS::Dist::Arch 1.32
pkgname=perl-www-shorten
-pkgver=3.06
+pkgver=3.093
pkgrel=1
pkgdesc='Interface to URL shortening sites'
arch=('any')
url='https://metacpan.org/release/WWW-Shorten'
license=('PerlArtistic' 'GPL')
-depends=('perl' 'perl-libwww')
+depends=('perl-libwww' 'perl-try-tiny')
optdepends=('perl-config-auto: for configuration file support')
-source=(http://search.cpan.org/CPAN/authors/id/D/DA/DAVECROSS/WWW-Shorten-3.06.tar.gz)
+source=(http://search.cpan.org/CPAN/authors/id/C/CA/CAPOEIRAB/WWW-Shorten-3.093.tar.gz)
options=(!emptydirs)
-md5sums=('7fec4441d031973710ee61999f964bd2')
+md5sums=('44bfbdd42ed459bf1e87291202ed35cf')
sanitize() {
unset PERL5LIB PERL_MM_OPT PERL_MB_OPT PERL_LOCAL_LIB_ROOT
@@ -21,20 +21,20 @@ sanitize() {
}
build() {
- cd WWW-Shorten-3.06
+ cd WWW-Shorten-3.093
sanitize
/usr/bin/perl Makefile.PL INSTALLDIRS=vendor
make
}
check() {
- cd WWW-Shorten-3.06
+ cd WWW-Shorten-3.093
sanitize
make test
}
package() {
- cd WWW-Shorten-3.06
+ cd WWW-Shorten-3.093
sanitize
make install DESTDIR="$pkgdir"
find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
diff --git a/PKGBUILD.tt b/PKGBUILD.tt
index 5937fcfa28a6..3267110b362c 100644
--- a/PKGBUILD.tt
+++ b/PKGBUILD.tt
@@ -9,7 +9,7 @@ pkgdesc='Interface to URL shortening sites'
arch=('any')
url='[% url %]'
license=('PerlArtistic' 'GPL')
-depends=('perl' 'perl-libwww')
+depends=('perl-libwww' 'perl-try-tiny')
optdepends=('perl-config-auto: for configuration file support')
source=([% source %])
options=(!emptydirs)