summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnton Leontiev2015-08-16 07:42:17 +0300
committerAnton Leontiev2015-08-16 07:42:17 +0300
commitdd4cb3f6a379d3077184464a3b99eca5e7e4733f (patch)
tree03e16bb075d7d2c9e074ff8bf99a0f6bfc536630
parent06f36135b743043cddbeec2c6acfad1279e3dc03 (diff)
downloadaur-dd4cb3f6a379d3077184464a3b99eca5e7e4733f.tar.gz
Updated to v3.06
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD34
-rw-r--r--PKGBUILD.tt24
3 files changed, 41 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b2f2385186f0..71eb0e73bab6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = perl-www-shorten
pkgdesc = Interface to URL shortening sites
- pkgver = 3.05
+ pkgver = 3.06
pkgrel = 1
- url = http://search.cpan.org/dist/WWW-Shorten
+ url = https://metacpan.org/release/WWW-Shorten
arch = any
license = PerlArtistic
license = GPL
@@ -10,8 +10,8 @@ pkgbase = perl-www-shorten
depends = perl-libwww
optdepends = perl-config-auto: for configuration file support
options = !emptydirs
- source = http://search.cpan.org/CPAN/authors/id/D/DA/DAVECROSS/WWW-Shorten-3.05.tar.gz
- md5sums = bdc5be1fac9ec6310e7c8163f29f4d47
+ source = http://search.cpan.org/CPAN/authors/id/D/DA/DAVECROSS/WWW-Shorten-3.06.tar.gz
+ md5sums = 7fec4441d031973710ee61999f964bd2
pkgname = perl-www-shorten
diff --git a/PKGBUILD b/PKGBUILD
index 8ef4fe586fcf..9ca416f53a32 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,41 @@
# CPAN Name : WWW::Shorten
# Contributor: Anton Leontiev <bunder /at/ t-25.ru>
-# Generator : CPANPLUS::Dist::Arch 1.29
+# Generator : CPANPLUS::Dist::Arch 1.30
pkgname=perl-www-shorten
-pkgver=3.05
+pkgver=3.06
pkgrel=1
pkgdesc='Interface to URL shortening sites'
arch=('any')
-url='http://search.cpan.org/dist/WWW-Shorten'
+url='https://metacpan.org/release/WWW-Shorten'
license=('PerlArtistic' 'GPL')
depends=('perl' 'perl-libwww')
optdepends=('perl-config-auto: for configuration file support')
-source=(http://search.cpan.org/CPAN/authors/id/D/DA/DAVECROSS/WWW-Shorten-3.05.tar.gz)
+source=(http://search.cpan.org/CPAN/authors/id/D/DA/DAVECROSS/WWW-Shorten-3.06.tar.gz)
options=(!emptydirs)
-md5sums=('bdc5be1fac9ec6310e7c8163f29f4d47')
+md5sums=('7fec4441d031973710ee61999f964bd2')
+
+sanitize() {
+ unset PERL5LIB PERL_MM_OPT PERL_MB_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL="--skipdeps" MODULEBUILDRC=/dev/null
+}
build() {
- cd WWW-Shorten-3.05
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
- make
+ cd WWW-Shorten-3.06
+ sanitize
+ /usr/bin/perl Makefile.PL INSTALLDIRS=vendor
+ make
}
check() {
- cd WWW-Shorten-3.05
- make test
+ cd WWW-Shorten-3.06
+ sanitize
+ make test
}
package() {
- cd WWW-Shorten-3.05
- make install DESTDIR="$pkgdir"
- find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+ cd WWW-Shorten-3.06
+ sanitize
+ make install DESTDIR="$pkgdir"
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
}
diff --git a/PKGBUILD.tt b/PKGBUILD.tt
index 793365b98e79..5937fcfa28a6 100644
--- a/PKGBUILD.tt
+++ b/PKGBUILD.tt
@@ -15,19 +15,27 @@ source=([% source %])
options=(!emptydirs)
md5sums=('[% md5sums %]')
+sanitize() {
+ unset PERL5LIB PERL_MM_OPT PERL_MB_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL="--skipdeps" MODULEBUILDRC=/dev/null
+}
+
build() {
- cd [% distdir %]
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
- make
+ cd [% distdir %]
+ sanitize
+ /usr/bin/perl Makefile.PL INSTALLDIRS=vendor
+ make
}
check() {
- cd [% distdir %]
- make test
+ cd [% distdir %]
+ sanitize
+ make test
}
package() {
- cd [% distdir %]
- make install DESTDIR="$pkgdir"
- find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+ cd [% distdir %]
+ sanitize
+ make install DESTDIR="$pkgdir"
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
}