summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn D Jones III2015-06-16 16:18:28 -0600
committerJohn D Jones III2015-06-16 16:18:28 -0600
commit57802298697997956b145a7ed631e69eb8e5b00c (patch)
treec39871b382716a12425666210ec00c89a64c4ef7
downloadaur-57802298697997956b145a7ed631e69eb8e5b00c.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD32
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8620c86e2646
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = perl-www-wikipedia
+ pkgdesc = Automated interface to the Wikipedia
+ pkgver = 2.01
+ pkgrel = 1
+ url = http://search.cpan.org/dist/WWW-Wikipedia
+ arch = i686
+ arch = x86_64
+ license = GPL
+ license = PerlArtistic
+ depends = perl>=5.10.0
+ depends = perl-text-autoformat
+ depends = perl-libwww
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/B/BR/BRICAS/WWW-Wikipedia-2.01.tar.gz
+ md5sums = 68a5f07f2add4e5a8aa591c24aa6fa75
+
+pkgname = perl-www-wikipedia
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..34fb3dcbbe75
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Jakob Nixdorf <flocke [swirly thing] shadowice [dot] org>
+
+pkgname=perl-www-wikipedia
+pkgver=2.01
+pkgrel=1
+pkgdesc="Automated interface to the Wikipedia"
+depends=('perl>=5.10.0' 'perl-text-autoformat' 'perl-libwww')
+license=('GPL' 'PerlArtistic')
+url="http://search.cpan.org/dist/WWW-Wikipedia"
+source=(http://search.cpan.org/CPAN/authors/id/B/BR/BRICAS/WWW-Wikipedia-${pkgver}.tar.gz)
+options=('!emptydirs')
+arch=(i686 x86_64)
+
+build()
+{
+ cd ${srcdir}/WWW-Wikipedia-${pkgver}
+
+ perl Makefile.PL INSTALLDIRS=vendor || return 1
+ make || return 1
+}
+
+package()
+{
+ cd ${srcdir}/WWW-Wikipedia-${pkgver}
+
+ make DESTDIR=${pkgdir} install || return 1
+
+ # Remove .packlist and perllocal.pod files.
+ find ${pkgdir} -name '.packlist' -delete
+ find ${pkgdir} -name 'perllocal.pod' -delete
+}
+md5sums=('68a5f07f2add4e5a8aa591c24aa6fa75')