summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSwift Geek2015-05-20 00:02:33 +0000
committerKyle Keen2015-05-20 00:02:33 +0000
commit16954393f5b8db5c40db1bbda98a526aa2938aea (patch)
tree1bfd300888082520ad50382a54ca90aaca4d330b
parent6784a2b9e81e017989c3bc6b37c138a1f8e19fcd (diff)
downloadaur-16954393f5b8db5c40db1bbda98a526aa2938aea.tar.gz
Import from pkgbuild.com service
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD8
2 files changed, 8 insertions, 1 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6513b882cb19..2ffe248d1f07 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,6 +7,7 @@ pkgbase = perl-wx-glcanvas
license = GPL
license = PerlArtistic
makedepends = perl-alien-wxwidgets
+ makedepends = xorg-server-xvfb
depends = perl>=5.10.0
depends = perl-wx
options = !emptydirs
diff --git a/PKGBUILD b/PKGBUILD
index ffae2adb7c43..428d131de0c6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,6 +8,7 @@ url="https://metacpan.org/release/Wx-GLCanvas/"
license=('GPL' 'PerlArtistic')
depends=('perl>=5.10.0' 'perl-wx')
makedepends=('perl-alien-wxwidgets')
+[ -z "$DISPLAY" ] && makedepends+=('xorg-server-xvfb')
provides=()
conflicts=()
replaces=()
@@ -40,7 +41,12 @@ build() {
check () {
cd "$_src_dir"
warning "If tests do fail - uninstall this package before compiling"
- prove -Iblib/arch -Iblib/lib/ t/
+ if [ -z "$DISPLAY" ]; then
+ warning "Empty \$DISPLAY - falling back to xvfb-run (xorg-server-xvfb)"
+ xvfb-run -a -s "+extension GLX -screen 0 1280x1024x24" prove -Iblib/arch -Iblib/lib/ t/
+ else
+ prove -Iblib/arch -Iblib/lib/ t/
+ fi
}
package () {