summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnton Leontiev2014-06-10 23:01:09 +0400
committerAnton Leontiev2015-02-15 07:48:22 +0300
commitbac1b72825d250a341b1ba38b7161db646591805 (patch)
tree2a7228c376378d8ae2e3927a95c63a93e0dbcb70
downloadaur-bac1b72825d250a341b1ba38b7161db646591805.tar.gz
Initial v0.94
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD37
-rw-r--r--PKGBUILD.tt37
4 files changed, 99 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1b857de9ccce
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = perl-xml-compile-c14n
+ pkgdesc = Perl package for XML canonicalization
+ pkgver = 0.94
+ pkgrel = 1
+ url = http://search.cpan.org/dist/XML-Compile-C14N
+ arch = any
+ license = PerlArtistic
+ license = GPL
+ checkdepends = perl>=5.13.11
+ depends = perl-xml-libxml>=1.94
+ depends = perl-xml-compile>=1.30
+ depends = perl-xml-compile-cache>=0.995
+ depends = perl-log-report>=0.991
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/M/MA/MARKOV/XML-Compile-C14N-0.94.tar.gz
+ md5sums = b98e76215074866a2058414432188cc9
+
+pkgname = perl-xml-compile-c14n
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e6b6b4b8077d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+*.tar.gz
+*.tar.bz2
+*.tar.xz
+*.tar.lz
+src/
+pkg/ \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b753ada8af0a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# CPAN Name : XML::Compile::C14N
+# Contributor: Anton Leontiev <bunder /at/ t-25.ru>
+# Generator : CPANPLUS::Dist::Arch 1.28
+
+pkgname=perl-xml-compile-c14n
+pkgver=0.94
+pkgrel=1
+pkgdesc='Perl package for XML canonicalization'
+arch=('any')
+url='http://search.cpan.org/dist/XML-Compile-C14N'
+license=('PerlArtistic' 'GPL')
+depends=(
+ 'perl-xml-libxml>=1.94'
+ 'perl-xml-compile>=1.30'
+ 'perl-xml-compile-cache>=0.995'
+ 'perl-log-report>=0.991')
+checkdepends=('perl>=5.13.11')
+source=(http://search.cpan.org/CPAN/authors/id/M/MA/MARKOV/XML-Compile-C14N-0.94.tar.gz)
+options=(!emptydirs)
+md5sums=('b98e76215074866a2058414432188cc9')
+
+build() {
+ cd XML-Compile-C14N-0.94
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ cd XML-Compile-C14N-0.94
+ make test
+}
+
+package() {
+ cd XML-Compile-C14N-0.94
+ make install DESTDIR="$pkgdir"
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
diff --git a/PKGBUILD.tt b/PKGBUILD.tt
new file mode 100644
index 000000000000..95d86d88958a
--- /dev/null
+++ b/PKGBUILD.tt
@@ -0,0 +1,37 @@
+# CPAN Name : XML::Compile::C14N
+# Contributor: [% packager %]
+# Generator : CPANPLUS::Dist::Arch [% version %]
+
+pkgname=[% pkgname %]
+pkgver=[% pkgver %]
+pkgrel=[% pkgrel %]
+pkgdesc='Perl package for XML canonicalization'
+arch=('any')
+url='[% url %]'
+license=('PerlArtistic' 'GPL')
+depends=(
+ 'perl-xml-libxml>=1.94'
+ 'perl-xml-compile>=1.30'
+ 'perl-xml-compile-cache>=0.995'
+ 'perl-log-report>=0.991')
+checkdepends=('perl>=5.13.11')
+source=([% source %])
+options=(!emptydirs)
+md5sums=('[% md5sums %]')
+
+build() {
+ cd [% distdir %]
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ cd [% distdir %]
+ make test
+}
+
+package() {
+ cd [% distdir %]
+ make install DESTDIR="$pkgdir"
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}