summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnton Leontiev2015-08-16 07:54:36 +0300
committerAnton Leontiev2015-08-16 07:54:36 +0300
commit5780f994548b0ee077b2ab336b11352bc5470983 (patch)
tree33542049fcf584508bdbc446ab68006e921ce846
parent317c318ed6495015669ad9100c79274faeb2ea4c (diff)
downloadaur-5780f994548b0ee077b2ab336b11352bc5470983.tar.gz
Updated to v1.03
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD32
-rw-r--r--PKGBUILD.tt16
3 files changed, 42 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7e873662018c..dfa2354b2b6e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,18 @@
pkgbase = perl-xml-compile-cache
pkgdesc = Perl package providing cache for compiled XML translators
- pkgver = 1.02
+ pkgver = 1.03
pkgrel = 1
- url = http://search.cpan.org/dist/XML-Compile-Cache
+ url = https://metacpan.org/release/XML-Compile-Cache
arch = any
license = PerlArtistic
license = GPL
- depends = perl-xml-compile>=1.41
+ depends = perl-xml-compile>=1.48
depends = perl-xml-compile-tester>=0.02
- depends = perl-xml-libxml-simple>=0.13
+ depends = perl-xml-libxml-simple>=0.95
depends = perl-log-report>=0.19
options = !emptydirs
- source = http://search.cpan.org/CPAN/authors/id/M/MA/MARKOV/XML-Compile-Cache-1.02.tar.gz
- md5sums = a72a4b5e726c51d8060438baf70e815d
+ source = http://search.cpan.org/CPAN/authors/id/M/MA/MARKOV/XML-Compile-Cache-1.03.tar.gz
+ md5sums = 57e99c0434e1220eaf8fa1ce095ec008
pkgname = perl-xml-compile-cache
diff --git a/PKGBUILD b/PKGBUILD
index 714653870247..f7cb65fc1f8b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,44 @@
# CPAN Name : XML::Compile::Cache
# Contributor: Anton Leontiev <bunder /at/ t-25.ru>
-# Generator : CPANPLUS::Dist::Arch 1.28
+# Generator : CPANPLUS::Dist::Arch 1.30
pkgname=perl-xml-compile-cache
-pkgver=1.02
+pkgver=1.03
pkgrel=1
pkgdesc='Perl package providing cache for compiled XML translators'
arch=('any')
-url='http://search.cpan.org/dist/XML-Compile-Cache'
+url='https://metacpan.org/release/XML-Compile-Cache'
license=('PerlArtistic' 'GPL')
-depends=('perl-xml-compile>=1.41' 'perl-xml-compile-tester>=0.02' 'perl-xml-libxml-simple>=0.13' 'perl-log-report>=0.19')
-source=(http://search.cpan.org/CPAN/authors/id/M/MA/MARKOV/XML-Compile-Cache-1.02.tar.gz)
+depends=(
+ 'perl-xml-compile>=1.48'
+ 'perl-xml-compile-tester>=0.02'
+ 'perl-xml-libxml-simple>=0.95'
+ 'perl-log-report>=0.19')
+source=(http://search.cpan.org/CPAN/authors/id/M/MA/MARKOV/XML-Compile-Cache-1.03.tar.gz)
options=(!emptydirs)
-md5sums=('a72a4b5e726c51d8060438baf70e815d')
+md5sums=('57e99c0434e1220eaf8fa1ce095ec008')
+
+sanitize() {
+ unset PERL5LIB PERL_MM_OPT PERL_MB_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL="--skipdeps" MODULEBUILDRC=/dev/null
+}
build() {
- cd XML-Compile-Cache-1.02
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ cd XML-Compile-Cache-1.03
+ sanitize
+ /usr/bin/perl Makefile.PL INSTALLDIRS=vendor
make
}
check() {
- cd XML-Compile-Cache-1.02
+ cd XML-Compile-Cache-1.03
+ sanitize
make test
}
package() {
- cd XML-Compile-Cache-1.02
+ cd XML-Compile-Cache-1.03
+ sanitize
make install DESTDIR="$pkgdir"
find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
}
diff --git a/PKGBUILD.tt b/PKGBUILD.tt
index 47108d078b34..1771954b8b3f 100644
--- a/PKGBUILD.tt
+++ b/PKGBUILD.tt
@@ -9,24 +9,36 @@ pkgdesc='Perl package providing cache for compiled XML translators'
arch=('any')
url='[% url %]'
license=('PerlArtistic' 'GPL')
-depends=('perl-xml-compile>=1.41' 'perl-xml-compile-tester>=0.02' 'perl-xml-libxml-simple>=0.13' 'perl-log-report>=0.19')
+depends=(
+ 'perl-xml-compile>=1.48'
+ 'perl-xml-compile-tester>=0.02'
+ 'perl-xml-libxml-simple>=0.95'
+ 'perl-log-report>=0.19')
source=([% source %])
options=(!emptydirs)
md5sums=('[% md5sums %]')
+sanitize() {
+ unset PERL5LIB PERL_MM_OPT PERL_MB_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL="--skipdeps" MODULEBUILDRC=/dev/null
+}
+
build() {
cd [% distdir %]
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ sanitize
+ /usr/bin/perl Makefile.PL INSTALLDIRS=vendor
make
}
check() {
cd [% distdir %]
+ sanitize
make test
}
package() {
cd [% distdir %]
+ sanitize
make install DESTDIR="$pkgdir"
find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
}