summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnton Leontiev2015-08-16 08:05:09 +0300
committerAnton Leontiev2015-08-16 08:05:09 +0300
commitbc9db1027502e418e90657fb6988e5fc8de1b47c (patch)
tree2f16407ce1a45ae650af31e94168a814a6680780
parentf0fb870a4317ce55fd0016f2591de51daaa63242 (diff)
downloadaur-bc9db1027502e418e90657fb6988e5fc8de1b47c.tar.gz
Updated to v3.03
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD28
-rw-r--r--PKGBUILD.tt12
3 files changed, 33 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0885e0a7881e..8a0ed046390f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = perl-xml-compile-soap12
pkgdesc = Perl package that handles SOAP v1.2 protocol
- pkgver = 3.02
+ pkgver = 3.03
pkgrel = 1
- url = http://search.cpan.org/dist/XML-Compile-SOAP12
+ url = https://metacpan.org/release/XML-Compile-SOAP12
arch = any
license = PerlArtistic
license = GPL
@@ -10,10 +10,10 @@ pkgbase = perl-xml-compile-soap12
depends = perl-xml-compile>=1.40
depends = perl-xml-compile-tester>=0.05
depends = perl-xml-compile-cache>=0.995
- depends = perl-xml-compile-soap>=3.04
+ depends = perl-xml-compile-soap>=3.08
options = !emptydirs
- source = http://search.cpan.org/CPAN/authors/id/M/MA/MARKOV/XML-Compile-SOAP12-3.02.tar.gz
- md5sums = 0a5b398bb35541152e324b4e7b4063f1
+ source = http://search.cpan.org/CPAN/authors/id/M/MA/MARKOV/XML-Compile-SOAP12-3.03.tar.gz
+ md5sums = ec095c530d146104be7e20220414ec85
pkgname = perl-xml-compile-soap12
diff --git a/PKGBUILD b/PKGBUILD
index 124439a59ed9..7d560510ad1b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,45 @@
# CPAN Name : XML::Compile::SOAP12
# Contributor: Anton Leontiev <bunder /at/ t-25.ru>
-# Generator : CPANPLUS::Dist::Arch 1.28
+# Generator : CPANPLUS::Dist::Arch 1.30
pkgname=perl-xml-compile-soap12
-pkgver=3.02
+pkgver=3.03
pkgrel=1
pkgdesc='Perl package that handles SOAP v1.2 protocol'
arch=('any')
-url='http://search.cpan.org/dist/XML-Compile-SOAP12'
+url='https://metacpan.org/release/XML-Compile-SOAP12'
license=('PerlArtistic' 'GPL')
depends=(
'perl-xml-compile>=1.40'
'perl-xml-compile-tester>=0.05'
'perl-xml-compile-cache>=0.995'
- 'perl-xml-compile-soap>=3.04')
+ 'perl-xml-compile-soap>=3.08')
checkdepends=('perl-test-deep>=0.095')
-source=(http://search.cpan.org/CPAN/authors/id/M/MA/MARKOV/XML-Compile-SOAP12-3.02.tar.gz)
+source=(http://search.cpan.org/CPAN/authors/id/M/MA/MARKOV/XML-Compile-SOAP12-3.03.tar.gz)
options=(!emptydirs)
-md5sums=('0a5b398bb35541152e324b4e7b4063f1')
+md5sums=('ec095c530d146104be7e20220414ec85')
+
+sanitize() {
+ unset PERL5LIB PERL_MM_OPT PERL_MB_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL="--skipdeps" MODULEBUILDRC=/dev/null
+}
build() {
- cd XML-Compile-SOAP12-3.02
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ cd XML-Compile-SOAP12-3.03
+ sanitize
+ /usr/bin/perl Makefile.PL INSTALLDIRS=vendor
make
}
check() {
- cd XML-Compile-SOAP12-3.02
+ cd XML-Compile-SOAP12-3.03
+ sanitize
make test
}
package() {
- cd XML-Compile-SOAP12-3.02
+ cd XML-Compile-SOAP12-3.03
+ sanitize
make install DESTDIR="$pkgdir"
find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
}
diff --git a/PKGBUILD.tt b/PKGBUILD.tt
index 0b0f398254b2..e4804904de78 100644
--- a/PKGBUILD.tt
+++ b/PKGBUILD.tt
@@ -13,25 +13,33 @@ depends=(
'perl-xml-compile>=1.40'
'perl-xml-compile-tester>=0.05'
'perl-xml-compile-cache>=0.995'
- 'perl-xml-compile-soap>=3.04')
+ 'perl-xml-compile-soap>=3.08')
checkdepends=('perl-test-deep>=0.095')
source=([% source %])
options=(!emptydirs)
md5sums=('[% md5sums %]')
+sanitize() {
+ unset PERL5LIB PERL_MM_OPT PERL_MB_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL="--skipdeps" MODULEBUILDRC=/dev/null
+}
+
build() {
cd [% distdir %]
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ sanitize
+ /usr/bin/perl Makefile.PL INSTALLDIRS=vendor
make
}
check() {
cd [% distdir %]
+ sanitize
make test
}
package() {
cd [% distdir %]
+ sanitize
make install DESTDIR="$pkgdir"
find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
}