summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn D Jones III2016-04-24 17:52:30 -0600
committerJohn D Jones III2016-04-24 17:52:30 -0600
commitb9b016dbb55d7e76e7feb8ee74e074aea8e186be (patch)
treecb7a90156cb1b9495249c215033f828b9f06f340
parent4ad5753c07c5ff26d6c24df62cc1c1f939c46344 (diff)
downloadaur-b9b016dbb55d7e76e7feb8ee74e074aea8e186be.tar.gz
Add patch to ensure tests always pass
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD7
-rw-r--r--XML-Hash-LX-0.0603-Fix-unpredictable-order-at-empty-attr-test.patch31
3 files changed, 38 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 230e23098128..26c7e1b6f49f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Sun Apr 24 23:46:03 UTC 2016
+# Sun Apr 24 23:50:56 UTC 2016
pkgbase = perl-xml-hash-lx
pkgdesc = Convert hash to xml and xml to hash using LibXML
pkgver = 0.0603
@@ -13,8 +13,9 @@ pkgbase = perl-xml-hash-lx
depends = perl>=5.6.2
options = !emptydirs
source = http://search.cpan.org/CPAN/authors/id/M/MO/MONS/XML-Hash-LX-0.0603.tar.gz
+ source = XML-Hash-LX-0.0603-Fix-unpredictable-order-at-empty-attr-test.patch
md5sums = 43103ac528427f1cf7212ad5412ade2d
- sha512sums = d31af10d5ae924c86d439bd38643a84c13d7c1a9085c4f89534644025b18bc1cfbac96d767e8541e2ba7dd702012732ce3bd394bfb10f5248bfab6ccc6f689e3
+ md5sums = abed43872f86f69892ca6754962106e0
pkgname = perl-xml-hash-lx
diff --git a/PKGBUILD b/PKGBUILD
index 2ed528de70b7..72d4c0b12cc6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,9 +11,9 @@ options=('!emptydirs')
depends=('perl-xml-libxml' 'perl>=5.6.2')
makedepends=('perl-lib-abs>=0.90')
url='https://metacpan.org/release/XML-Hash-LX'
-source=('http://search.cpan.org/CPAN/authors/id/M/MO/MONS/XML-Hash-LX-0.0603.tar.gz')
-md5sums=('43103ac528427f1cf7212ad5412ade2d')
-sha512sums=('d31af10d5ae924c86d439bd38643a84c13d7c1a9085c4f89534644025b18bc1cfbac96d767e8541e2ba7dd702012732ce3bd394bfb10f5248bfab6ccc6f689e3')
+source=('http://search.cpan.org/CPAN/authors/id/M/MO/MONS/XML-Hash-LX-0.0603.tar.gz' 'XML-Hash-LX-0.0603-Fix-unpredictable-order-at-empty-attr-test.patch')
+md5sums=('43103ac528427f1cf7212ad5412ade2d' 'abed43872f86f69892ca6754962106e0')
+
_distdir="XML-Hash-LX-0.0603"
build() {
@@ -24,6 +24,7 @@ build() {
MODULEBUILDRC=/dev/null
cd "$srcdir/$_distdir"
+ patch -Np1 -i ../XML-Hash-LX-0.0603-Fix-unpredictable-order-at-empty-attr-test.patch
/usr/bin/perl Makefile.PL
make
)
diff --git a/XML-Hash-LX-0.0603-Fix-unpredictable-order-at-empty-attr-test.patch b/XML-Hash-LX-0.0603-Fix-unpredictable-order-at-empty-attr-test.patch
new file mode 100644
index 000000000000..7633244237d5
--- /dev/null
+++ b/XML-Hash-LX-0.0603-Fix-unpredictable-order-at-empty-attr-test.patch
@@ -0,0 +1,31 @@
+From 19c3c8bbb1646dc5bfe7f0d3df5efb3ba58ada80 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Petr=20P=C3=ADsa=C5=99?= <ppisar@redhat.com>
+Date: Mon, 9 Jun 2014 17:41:32 +0200
+Subject: [PATCH] Fix unpredictable order at 'empty attr' test
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+RT#81645
+
+Signed-off-by: Petr Písař <ppisar@redhat.com>
+---
+ t/01-conv.t | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/t/01-conv.t b/t/01-conv.t
+index f7b06c5..30f24dc 100644
+--- a/t/01-conv.t
++++ b/t/01-conv.t
+@@ -297,7 +297,7 @@ our $xml = qq{<?xml version="1.0" encoding="utf-8"?>\n};
+ }
+ {
+ is
+- $data = hash2xml( { node => { -attr => undef, '#cdata' => undef, '/' => undef, x=>undef } }, cdata => '#cdata', comm => '/' ),
++ $data = hash2xml( { node => [ { -attr => undef }, { '#cdata' => undef }, { '/' => undef }, { x=>undef } ] }, cdata => '#cdata', comm => '/' ),
+ qq{$xml<node attr=""><!----><x/></node>\n},
+ 'empty attr',
+ ;
+--
+1.9.3
+