summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakob Gahde2022-02-15 02:30:27 +0100
committerJakob Gahde2022-02-15 02:30:27 +0100
commit7b4fa8ae3e3aca4d039f21089bc69ae62e616c56 (patch)
treea7e2958b1050479690613887ec93c60d46b4df7d
downloadaur-7b4fa8ae3e3aca4d039f21089bc69ae62e616c56.tar.gz
perl-xml-spice 0.05-1: Create new package
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD32
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a7709132385f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = perl-xml-spice
+ pkgdesc = Yet another XML generation module
+ pkgver = 0.05
+ pkgrel = 1
+ url = https://github.com/robn/XML-Spice
+ arch = any
+ license = GPL
+ license = PerlArtistic
+ checkdepends = perl-test-xml
+ depends = perl
+ depends = perl-xml-tidy-tiny
+ source = https://www.cpan.org/modules/by-module/XML/XML-Spice-0.05.tar.gz
+ sha512sums = c08bc5379f1a74144efc399539cd4910a395bd92fb5f21b913cc12c9e456c80f12201333fe1ba3a7d60745c5f07222dfbc82e50de1d42bea813c5665dae6a0ea
+
+pkgname = perl-xml-spice
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a1c312eafe28
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
+
+pkgname=perl-xml-spice
+pkgver=0.05
+pkgrel=1
+pkgdesc="Yet another XML generation module"
+arch=('any')
+url="https://github.com/robn/XML-Spice"
+license=('GPL' 'PerlArtistic')
+depends=('perl' 'perl-xml-tidy-tiny')
+checkdepends=('perl-test-xml')
+source=("https://www.cpan.org/modules/by-module/XML/XML-Spice-${pkgver}.tar.gz")
+sha512sums=('c08bc5379f1a74144efc399539cd4910a395bd92fb5f21b913cc12c9e456c80f12201333fe1ba3a7d60745c5f07222dfbc82e50de1d42bea813c5665dae6a0ea')
+
+build() {
+ cd "${srcdir}/XML-Spice-${pkgver}"
+
+ perl Makefile.PL NO_PACKLIST=true NO_PERLLOCAL=true
+ make
+}
+
+check() {
+ cd "${srcdir}/XML-Spice-${pkgver}"
+
+ make test
+}
+
+package() {
+ cd "${srcdir}/XML-Spice-${pkgver}"
+
+ make install INSTALLDIRS=vendor DESTDIR="${pkgdir}"
+}