summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKåre Hampf2015-10-17 14:57:30 +0300
committerKåre Hampf2015-10-17 14:57:30 +0300
commitc33618f506ba00d6b5b7d3ccc6af756d6d4bda56 (patch)
treea82b5c2a679772a27a0fcca21928364e6872489d
parentbdc6147dcec678831e903b2d40fb5c25b5d34561 (diff)
downloadaur-c33618f506ba00d6b5b7d3ccc6af756d6d4bda56.tar.gz
rewritten PKGBUILD
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD64
2 files changed, 26 insertions, 45 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4b586f1e172d..30a27eb01b50 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -2,13 +2,14 @@ pkgbase = perl-xml-treepp
pkgdesc = XML::TreePP module parses an XML document and expands it for a hash tree.
pkgver = 0.43
pkgrel = 2
- url = http://search.cpan.org/~kawasaki/XML-TreePP-0.43/
+ url = https://metacpan.org/release/XML-TreePP
arch = any
license = GPL
license = PerlArtistic
- depends = perl>=5.10.0
+ depends = perl
options = !emptydirs
- source = http://cpan.perl.org/modules/by-authors/id/K/KA/KAWASAKI/XML-TreePP-0.43.tar.gz
+ options = purge
+ source = http://search.cpan.org/CPAN/authors/id/K/KA/KAWASAKI/XML-TreePP-0.43.tar.gz
md5sums = f69693066e52591bf1142d3f4e6d37e5
pkgname = perl-xml-treepp
diff --git a/PKGBUILD b/PKGBUILD
index df8985c6e73c..a935963b4fec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,55 +1,35 @@
-# I just put this together in a hurry based on what I found in ABS, it's uggly I know /KH
-
-# This is an example PKGBUILD file. Use this as a start to creating your own,
-# and remove these comments. For more information, see 'man PKGBUILD'.
-# NOTE: Please fill out the license field for your package! If it is unknown,
-# then please put 'unknown'.
-
-# See http://wiki.archlinux.org/index.php/Perl_Package_Guidelines for more
-# information on Perl packaging.
-
-# Maintainer: K. Hampf <k.hampf@gmail.com>
-# http://search.cpan.org/CPAN/authors/id/K/KA/KAWASAKI/XML-TreePP-0.43.tar.gz
-_author=kawasaki
-_authorpath=K/KA/KAWASAKI # this is uggly
-_perlmod=XML-TreePP
+# Contributor: K. Hampf <k.hampf@gmail.com>
pkgname=perl-xml-treepp
+_authorpath=K/KA/KAWASAKI # this is uggly
pkgver=0.43
pkgrel=2
-pkgdesc="XML::TreePP module parses an XML document and expands it for a hash tree."
-arch=(any)
-url="http://search.cpan.org/~$_author/$_perlmod-$pkgver/"
+pkgdesc='XML::TreePP module parses an XML document and expands it for a hash tree.'
+_dist=XML-TreePP
+arch=('any')
+url="https://metacpan.org/release/$_dist"
license=('GPL' 'PerlArtistic')
-groups=()
-depends=('perl>=5.10.0')
-makedepends=()
-provides=()
-conflicts=()
-replaces=()
-backup=()
-options=(!emptydirs)
-install=
-source=(http://cpan.perl.org/modules/by-authors/id/$_authorpath/$_perlmod-$pkgver.tar.gz)
+depends=(perl)
+options=('!emptydirs' purge)
+source=("http://search.cpan.org/CPAN/authors/id/$_authorpath/$_dist-$pkgver.tar.gz")
md5sums=('f69693066e52591bf1142d3f4e6d37e5')
build() {
- cd "$srcdir/$_perlmod-$pkgver"
-
- # Install module in vendor directories.
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ cd "$srcdir/$_dist-$pkgver"
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps
+ /usr/bin/perl Makefile.PL
make
+}
- ## For packages with Build.PL, do this instead:
- # perl Build.PL installdirs=vendor destdir="$pkgdir/"
- # perl Build
+check() {
+ cd "$srcdir/$_dist-$pkgver"
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1
+ make test
}
package() {
- cd "$srcdir/$_perlmod-$pkgver"
- make install DESTDIR="$pkgdir/"
-
- ## For packages with Build.PL, do this instead:
- # perl Build install
+ cd "$srcdir/$_dist-$pkgver"
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ make install INSTALLDIRS=vendor DESTDIR="$pkgdir"
}
-
-# vim:set ts=2 sw=2 et: