summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Weidenbaum2016-01-04 12:27:02 -0800
committerAndy Weidenbaum2016-01-04 12:27:02 -0800
commit26001ba8908d5924cbe60b6bc931da9b1ca779d1 (patch)
treea7f37b236ac324d55f655920bd3ed289420d8671
downloadaur-26001ba8908d5924cbe60b6bc931da9b1ca779d1.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD48
2 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..003811233ea0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Mon Jan 4 20:26:41 UTC 2016
+pkgbase = perl6-base64
+ pkgdesc = Lazy base64 encoding and decoding routines
+ pkgver = 0.0.1
+ pkgrel = 1
+ url = https://github.com/ugexe/Perl6-Base64
+ arch = any
+ groups = perl6
+ license = PerlArtistic
+ checkdepends = perl
+ makedepends = alacryd
+ makedepends = git
+ depends = rakudo
+ source = perl6-base64-0.0.1::git+https://github.com/ugexe/Perl6-Base64
+ sha256sums = SKIP
+
+pkgname = perl6-base64
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c8e2152dd38c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Andy Weidenbaum <archbaum@gmail.com>
+
+pkgname=perl6-base64
+pkgver=0.0.1
+pkgrel=1
+pkgdesc="Lazy base64 encoding and decoding routines"
+arch=('any')
+depends=('rakudo')
+checkdepends=('perl')
+makedepends=('alacryd' 'git')
+groups=('perl6')
+url="https://github.com/ugexe/Perl6-Base64"
+license=('PerlArtistic')
+source=($pkgname-$pkgver::git+https://github.com/ugexe/Perl6-Base64)
+sha256sums=('SKIP')
+
+check() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ msg2 'Running tests...'
+ PERL6LIB=lib prove -r -e perl6
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ msg2 'Installing documentation...'
+ install -Dm 644 README.pod -t "$pkgdir/usr/share/doc/$pkgname"
+
+ msg2 'Installing...'
+ install -dm 755 "$pkgdir/usr/share/perl6/vendor"
+ export RAKUDO_LOG_PRECOMP=1
+ export PERL6LIB="inst#$pkgdir/usr/share/perl6/vendor"
+ alacryd install
+
+ msg2 'Removing redundant precomp file dependencies...'
+ _precomp=($(pacman -Qg perl6 \
+ | awk '{print $2}' \
+ | xargs pacman -Ql \
+ | awk '{print $2}' \
+ | grep precomp))
+ for _pc in "${_precomp[@]}"; do
+ [[ -f "$pkgdir/$_pc" ]] && rm -f "$pkgdir/$_pc"
+ done
+
+ msg2 'Cleaning up pkgdir...'
+ find "$pkgdir" -type f -name "*.lock" -exec rm '{}' \;
+}