summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcell Meszaros2023-08-16 23:39:11 +0200
committerMarcell Meszaros2023-08-16 23:45:00 +0200
commit89819137791bf424e563906f538b7771a003700f (patch)
tree0700a1699042a1021077671383b39945b1ff7d10
parentbda38b1bd29e7102c7ab4ed730c9914fea849b53 (diff)
downloadaur-89819137791bf424e563906f538b7771a003700f.tar.gz
0.1.0-1: update, fix, and make it a proper non-VCS package
-rw-r--r--.SRCINFO11
-rw-r--r--.gitignore18
-rw-r--r--PKGBUILD25
3 files changed, 35 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3d05d6e5f965..2eb9bd8eec95 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,7 @@
-# Generated by mksrcinfo v8
-# Mon Aug 7 02:01:11 UTC 2017
pkgbase = perl6-base64
pkgdesc = Lazy base64 encoding and decoding routines
- pkgver = 0.0.1
- pkgrel = 3
+ pkgver = 0.1.0
+ pkgrel = 1
url = https://github.com/ugexe/Perl6-Base64
arch = any
groups = perl6
@@ -12,8 +10,7 @@ pkgbase = perl6-base64
makedepends = git
depends = perl6
options = !purge
- source = perl6-base64-0.0.1::git+https://github.com/ugexe/Perl6-Base64
- sha256sums = SKIP
+ source = perl6-base64::git+https://github.com/ugexe/Perl6-Base64.git#tag=v0.1.0
+ b2sums = SKIP
pkgname = perl6-base64
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..64306dbd455d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,18 @@
+# based on https://github.com/github/gitignore/blob/master/ArchLinuxPackages.gitignore
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/
+
+*.orig
+*.bak
+*.backup
diff --git a/PKGBUILD b/PKGBUILD
index ac260d1fa58d..7bee1bdf9bba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
-# Maintainer: Andy Weidenbaum <archbaum@gmail.com>
+# Contributor: Marcell Meszaros < marcell.meszaros AT runbox.eu >
+# Contributor: Andy Weidenbaum <archbaum@gmail.com>
pkgname=perl6-base64
-pkgver=0.0.1
-pkgrel=3
+pkgver=0.1.0
+pkgrel=1
pkgdesc="Lazy base64 encoding and decoding routines"
arch=('any')
depends=('perl6')
@@ -12,23 +13,23 @@ groups=('perl6')
url="https://github.com/ugexe/Perl6-Base64"
license=('PerlArtistic')
options=('!purge')
-source=($pkgname-$pkgver::git+https://github.com/ugexe/Perl6-Base64)
-sha256sums=('SKIP')
+source=("$pkgname::git+$url.git#tag=v$pkgver")
+b2sums=('SKIP')
check() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$srcdir/$pkgname"
- msg2 'Running tests...'
- PERL6LIB=lib prove -r -e perl6
+ echo 'Running tests...'
+ PERL6LIB=lib prove --ext .rakutest -v -e "raku -I." t/
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$srcdir/$pkgname"
- msg2 'Installing documentation...'
- install -Dm 644 README.pod -t "$pkgdir/usr/share/doc/$pkgname"
+ echo 'Installing documentation...'
+ install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname"
- msg2 'Installing...'
+ echo 'Installing...'
export RAKUDO_LOG_PRECOMP=1
export RAKUDO_RERESOLVE_DEPENDENCIES=0
perl6-install-dist \