summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Weidenbaum2017-09-06 23:04:47 -0700
committerAndy Weidenbaum2017-09-06 23:04:47 -0700
commit15709fde23be29851d33ab584eb75604aeba0400 (patch)
treefa8ed602272b0e9f3e0a935d0db1a0e21905f800
downloadaur-15709fde23be29851d33ab584eb75604aeba0400.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD40
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e26f112d1fcf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Thu Sep 7 06:04:16 UTC 2017
+pkgbase = perl6-cro-core
+ pkgdesc = Libraries for building reactive services in Perl6 - core
+ pkgver = 0.7
+ pkgrel = 1
+ url = https://github.com/croservices/cro-core
+ arch = any
+ groups = croservices
+ groups = perl6
+ license = PerlArtistic
+ checkdepends = perl
+ makedepends = git
+ depends = perl6
+ source = perl6-cro-core-0.7::git+https://github.com/croservices/cro-core
+ sha256sums = SKIP
+
+pkgname = perl6-cro-core
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8cef01344f99
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Andy Weidenbaum <archbaum@gmail.com>
+
+pkgname=perl6-cro-core
+pkgver=0.7
+pkgrel=1
+pkgdesc="Libraries for building reactive services in Perl6 - core"
+arch=('any')
+depends=('perl6')
+checkdepends=('perl')
+makedepends=('git')
+groups=('croservices' 'perl6')
+url="https://github.com/croservices/cro-core"
+license=('PerlArtistic')
+source=($pkgname-$pkgver::git+https://github.com/croservices/cro-core)
+sha256sums=('SKIP')
+
+check() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ msg2 'Running tests...'
+ PERL6LIB=lib prove -r -e perl6
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ msg2 'Installing license...'
+ install -Dm 644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
+
+ msg2 'Installing documentation...'
+ install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname"
+
+ msg2 'Installing...'
+ export RAKUDO_LOG_PRECOMP=1
+ export RAKUDO_RERESOLVE_DEPENDENCIES=0
+ perl6-install-dist \
+ --to="$pkgdir/usr/share/perl6/vendor" \
+ --for=vendor \
+ --from=.
+}