summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Weidenbaum2018-05-15 15:18:22 -0400
committerAndy Weidenbaum2018-05-15 15:18:22 -0400
commit5af31be9c05c57da7216f97a7c2c08ba693325d3 (patch)
tree52a5b262042752706adb23beb7feaf7cdc6c59f9
parent65ea534a20c527be16db4e74ccb0fe39968b710b (diff)
downloadaur-perl6-digest-xxhash.tar.gz
install wiki
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD12
2 files changed, 12 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index af749e4aa3c3..57e8038c462a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -11,6 +11,8 @@ pkgbase = perl6-digest-xxhash
depends = libxxhash
depends = perl6
source = perl6-digest-xxhash-1.0.1::git+https://github.com/atweiden/digest-xxhash
+ source = git+https://github.com/atweiden/digest-xxhash.wiki
+ sha256sums = SKIP
sha256sums = SKIP
pkgname = perl6-digest-xxhash
diff --git a/PKGBUILD b/PKGBUILD
index aff5ea0aa8b6..328c1d5583fd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,8 +11,9 @@ makedepends=('git')
groups=('perl6')
url="https://github.com/atweiden/digest-xxhash"
license=('UNLICENSE')
-source=($pkgname-$pkgver::git+https://github.com/atweiden/digest-xxhash)
-sha256sums=('SKIP')
+source=($pkgname-$pkgver::git+https://github.com/atweiden/digest-xxhash
+ git+https://github.com/atweiden/digest-xxhash.wiki)
+sha256sums=('SKIP' 'SKIP')
check() {
cd "$srcdir/$pkgname-$pkgver"
@@ -27,6 +28,10 @@ package() {
msg2 'Installing documentation...'
install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname"
+ msg2 'Installing wiki...'
+ cp -dpr --no-preserve=ownership "$srcdir/digest-xxhash.wiki" \
+ "$pkgdir/usr/share/doc/perl6-digest-xxhash/wiki"
+
msg2 'Installing...'
export RAKUDO_LOG_PRECOMP=1
export RAKUDO_RERESOLVE_DEPENDENCIES=0
@@ -34,4 +39,7 @@ package() {
--to="$pkgdir/usr/share/perl6/vendor" \
--for=vendor \
--from=.
+
+ msg2 'Cleaning up pkgdir...'
+ find "$pkgdir" -type d -name .git -exec rm -r '{}' +
}