summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Weidenbaum2016-01-25 14:58:13 -0800
committerAndy Weidenbaum2016-01-25 14:58:13 -0800
commit160abdc2f7e73a29d3f3c7d1a5a4a2a013568ffe (patch)
treed349716f85e98b7f5a62d7abcf6a142c60844386
downloadaur-160abdc2f7e73a29d3f3c7d1a5a4a2a013568ffe.tar.gz
Initial import
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD51
2 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7feb8575ee97
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Mon Jan 25 22:58:10 UTC 2016
+pkgbase = perl6-fastcgi-nativecall-psgi
+ pkgdesc = A PSGI interface for FastCGI::NativeCall
+ pkgver = 0.0.1
+ pkgrel = 1
+ url = https://github.com/carbin/p6-fcgi-psgi
+ arch = any
+ groups = perl6
+ license = MIT
+ checkdepends = perl
+ makedepends = alacryd
+ makedepends = git
+ depends = perl6
+ depends = perl6-fastcgi-nativecall
+ depends = perl6-psgi
+ source = perl6-fastcgi-nativecall-psgi-0.0.1::git+https://github.com/carbin/p6-fcgi-psgi
+ sha256sums = SKIP
+
+pkgname = perl6-fastcgi-nativecall-psgi
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f6e7a2d4d166
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Andy Weidenbaum <archbaum@gmail.com>
+
+pkgname=perl6-fastcgi-nativecall-psgi
+pkgver=0.0.1
+pkgrel=1
+pkgdesc="A PSGI interface for FastCGI::NativeCall"
+arch=('any')
+depends=('perl6' 'perl6-fastcgi-nativecall' 'perl6-psgi')
+checkdepends=('perl')
+makedepends=('alacryd' 'git')
+groups=('perl6')
+url="https://github.com/carbin/p6-fcgi-psgi"
+license=('MIT')
+source=($pkgname-$pkgver::git+https://github.com/carbin/p6-fcgi-psgi)
+sha256sums=('SKIP')
+
+check() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ msg2 'Running tests...'
+ PERL6LIB=lib prove -r -e perl6
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ msg2 'Installing license...'
+ install -Dm 644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
+
+ msg2 'Installing documentation...'
+ install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname"
+
+ msg2 'Installing...'
+ install -dm 755 "$pkgdir/usr/share/perl6/vendor"
+ export RAKUDO_LOG_PRECOMP=1
+ export PERL6LIB="inst#$pkgdir/usr/share/perl6/vendor"
+ alacryd install
+
+ msg2 'Removing redundant precomp file dependencies...'
+ _precomp=($(pacman -Qg perl6 \
+ | awk '{print $2}' \
+ | xargs pacman -Ql \
+ | awk '{print $2}' \
+ | grep precomp))
+ for _pc in "${_precomp[@]}"; do
+ [[ -f "$pkgdir/$_pc" ]] && rm -f "$pkgdir/$_pc"
+ done
+
+ msg2 'Cleaning up pkgdir...'
+ find "$pkgdir" -type f -name "*.lock" -exec rm '{}' \;
+}