summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Weidenbaum2016-07-02 09:11:03 -0700
committerAndy Weidenbaum2016-07-02 09:11:03 -0700
commitd7b1f7638c5560823667223c8799cc000a322782 (patch)
treea1fb4d36828027b597f4c6ad03ef6dc85174dfaf
downloadaur-d7b1f7638c5560823667223c8799cc000a322782.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD50
2 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0b06d2cb23bf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Sat Jul 2 16:10:56 UTC 2016
+pkgbase = perl6-file-presence
+ pkgdesc = Check that a file / directory exists and is readable
+ pkgver = 0.0.1
+ pkgrel = 1
+ url = https://github.com/atweiden/file-presence
+ arch = any
+ groups = perl6
+ license = UNLICENSE
+ checkdepends = perl
+ makedepends = alacryd
+ makedepends = git
+ depends = perl6
+ source = perl6-file-presence-0.0.1::git+https://github.com/atweiden/file-presence
+ sha256sums = SKIP
+
+pkgname = perl6-file-presence
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b6d45fb52037
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: Andy Weidenbaum <archbaum@gmail.com>
+
+pkgname=perl6-file-presence
+pkgver=0.0.1
+pkgrel=1
+pkgdesc="Check that a file / directory exists and is readable"
+arch=('any')
+depends=('perl6')
+checkdepends=('perl')
+makedepends=('alacryd' 'git')
+groups=('perl6')
+url="https://github.com/atweiden/file-presence"
+license=('UNLICENSE')
+source=($pkgname-$pkgver::git+https://github.com/atweiden/file-presence)
+sha256sums=('SKIP')
+
+check() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ msg2 'Running tests...'
+ PERL6LIB=lib prove -r -e perl6
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ msg2 'Installing license...'
+ install -Dm 644 UNLICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
+
+ msg2 'Installing documentation...'
+ install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname"
+
+ msg2 'Installing...'
+ install -dm 755 "$pkgdir/usr/share/perl6/vendor"
+ export RAKUDO_LOG_PRECOMP=1
+ export PERL6LIB="inst#$pkgdir/usr/share/perl6/vendor"
+ alacryd install
+
+ msg2 'Removing redundant precomp file dependencies...'
+ _precomp=($(pacman -Qqg perl6 | pacman -Qql - | grep -E 'dist|precomp' || true))
+ for _pc in "${_precomp[@]}"; do
+ [[ -f "$pkgdir/$_pc" ]] && rm -f "$pkgdir/$_pc"
+ done
+
+ msg2 'Cleaning up pkgdir...'
+ rm -f "$pkgdir/usr/share/perl6/vendor/version"
+ find "$pkgdir" -type f -name "*.lock" -exec rm '{}' +
+ find "$pkgdir" -type f -print0 -exec \
+ sed -i -e "s,$pkgdir,,g" -e "s,$srcdir,,g" '{}' +
+}