summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Weidenbaum2016-03-11 08:13:14 -0800
committerAndy Weidenbaum2016-03-11 08:13:14 -0800
commit9ee814b3ed82410e57ac79956858cf177e6ce486 (patch)
treee213812f75bb683f2261fd621f6ccc56781cf175
downloadaur-9ee814b3ed82410e57ac79956858cf177e6ce486.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD47
2 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..721159bf34bf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Fri Mar 11 16:13:04 UTC 2016
+pkgbase = perl6-file-which
+ pkgdesc = Finds the full or relative paths to an executable program on the system
+ pkgver = 0.0.1
+ pkgrel = 1
+ url = https://github.com/azawawi/perl6-file-which
+ arch = any
+ groups = perl6
+ license = PerlArtistic
+ checkdepends = perl
+ makedepends = alacryd
+ makedepends = git
+ depends = perl6
+ source = perl6-file-which-0.0.1::git+https://github.com/azawawi/perl6-file-which
+ sha256sums = SKIP
+
+pkgname = perl6-file-which
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d1b7bd0935ce
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Andy Weidenbaum <archbaum@gmail.com>
+
+pkgname=perl6-file-which
+pkgver=0.0.1
+pkgrel=1
+pkgdesc="Finds the full or relative paths to an executable program on the system"
+arch=('any')
+depends=('perl6')
+checkdepends=('perl')
+makedepends=('alacryd' 'git')
+groups=('perl6')
+url="https://github.com/azawawi/perl6-file-which"
+license=('PerlArtistic')
+source=($pkgname-$pkgver::git+https://github.com/azawawi/perl6-file-which)
+sha256sums=('SKIP')
+
+check() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ msg2 'Running tests...'
+ PERL6LIB=lib prove -r -e perl6
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ msg2 'Installing license...'
+ install -Dm 644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
+
+ msg2 'Installing documentation...'
+ install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname"
+
+ msg2 'Installing...'
+ install -dm 755 "$pkgdir/usr/share/perl6/vendor"
+ export RAKUDO_LOG_PRECOMP=1
+ export PERL6LIB="inst#$pkgdir/usr/share/perl6/vendor"
+ alacryd install
+
+ msg2 'Removing redundant precomp file dependencies...'
+ _precomp=($(pacman -Qqg perl6 | pacman -Qql - | grep -E 'dist|precomp' || true))
+ for _pc in "${_precomp[@]}"; do
+ [[ -f "$pkgdir/$_pc" ]] && rm -f "$pkgdir/$_pc"
+ done
+
+ msg2 'Cleaning up pkgdir...'
+ find "$pkgdir" -type f -name "*.lock" -exec rm '{}' \;
+}