summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Weidenbaum2015-11-22 18:51:46 -0800
committerAndy Weidenbaum2015-11-22 18:51:46 -0800
commitc629919bcc8c8317c8388693ffc63d021836914a (patch)
tree8a61a245a5f0b5a272b4ae88eb44283f8766b8b3
downloadaur-c629919bcc8c8317c8388693ffc63d021836914a.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD37
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7b0d821a8897
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = perl6-find-bundled
+ pkgdesc = A replacement for %?RESOURCE
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/retupmoca/P6-Find-Bundled
+ arch = any
+ groups = perl6
+ license = MIT
+ checkdepends = perl
+ makedepends = git
+ depends = rakudo
+ source = perl6-find-bundled-1.0.0::git+https://github.com/retupmoca/P6-Find-Bundled
+ sha256sums = SKIP
+
+pkgname = perl6-find-bundled
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b121841dafc5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Andy Weidenbaum <archbaum@gmail.com>
+
+pkgname=perl6-find-bundled
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="A replacement for %?RESOURCE"
+arch=('any')
+depends=('rakudo')
+checkdepends=('perl')
+makedepends=('git')
+groups=('perl6')
+url="https://github.com/retupmoca/P6-Find-Bundled"
+license=('MIT')
+source=($pkgname-$pkgver::git+https://github.com/retupmoca/P6-Find-Bundled)
+sha256sums=('SKIP')
+
+check() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ msg2 'Running tests...'
+ PERL6LIB=lib prove -r -e perl6
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ msg2 'Installing license...'
+ install -Dm 644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
+
+ msg2 'Installing documentation...'
+ install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname"
+
+ msg2 'Installing...'
+ mkdir -p "$pkgdir/usr/share/perl6/vendor/lib"
+ find lib -mindepth 1 -maxdepth 1 -exec \
+ cp -dpr --no-preserve=ownership '{}' "$pkgdir/usr/share/perl6/vendor/lib" \;
+}