summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Weidenbaum2015-12-18 00:14:19 -0800
committerAndy Weidenbaum2015-12-18 00:14:19 -0800
commitdfc4fd1b734d9950fc8f403fd1b36824fe6b9a8f (patch)
tree30fdef611694643397377392cb0225d533167d49
downloadaur-dfc4fd1b734d9950fc8f403fd1b36824fe6b9a8f.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD27
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fd77fa632385
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Fri Dec 18 08:13:04 UTC 2015
+pkgbase = perl6-html-parser
+ pkgdesc = Role for HTML parsing
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://github.com/tony-o/perl6-html-parser
+ arch = any
+ groups = perl6
+ license = PerlArtistic
+ checkdepends = perl
+ makedepends = git
+ depends = rakudo
+ depends = perl6-xml
+ source = perl6-html-parser-0.1::git+https://github.com/tony-o/perl6-html-parser
+ sha256sums = SKIP
+
+pkgname = perl6-html-parser
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ac9e497b800e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Andy Weidenbaum <archbaum@gmail.com>
+
+pkgname=perl6-html-parser
+pkgver=0.1
+pkgrel=1
+pkgdesc="Role for HTML parsing"
+arch=('any')
+depends=('rakudo' 'perl6-xml')
+checkdepends=('perl')
+makedepends=('git')
+groups=('perl6')
+url="https://github.com/tony-o/perl6-html-parser"
+license=('PerlArtistic')
+source=($pkgname-$pkgver::git+https://github.com/tony-o/perl6-html-parser)
+sha256sums=('SKIP')
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ msg2 'Installing documentation...'
+ install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname"
+
+ msg2 'Installing...'
+ mkdir -p "$pkgdir/usr/share/perl6/vendor/lib"
+ find lib -mindepth 1 -maxdepth 1 -exec \
+ cp -dpr --no-preserve=ownership '{}' "$pkgdir/usr/share/perl6/vendor/lib" \;
+}