summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Weidenbaum2016-01-04 18:45:44 -0800
committerAndy Weidenbaum2016-01-04 18:45:44 -0800
commit84d9a1d78393511548f19559a59ab3afb6d745ff (patch)
tree39d912d906dbbdd87039f2a4865f05b5193f858f
downloadaur-84d9a1d78393511548f19559a59ab3afb6d745ff.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD48
2 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4bd1ec44e624
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Tue Jan 5 02:45:42 UTC 2016
+pkgbase = perl6-http-status
+ pkgdesc = Get the text message associated with an HTTP status code
+ pkgver = 0.0.1
+ pkgrel = 1
+ url = https://github.com/supernovus/perl6-http-status
+ arch = any
+ groups = perl6
+ license = PerlArtistic
+ checkdepends = perl
+ makedepends = alacryd
+ makedepends = git
+ depends = perl6
+ source = perl6-http-status-0.0.1::git+https://github.com/supernovus/perl6-http-status
+ sha256sums = SKIP
+
+pkgname = perl6-http-status
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dd3e0e1d9e45
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Andy Weidenbaum <archbaum@gmail.com>
+
+pkgname=perl6-http-status
+pkgver=0.0.1
+pkgrel=1
+pkgdesc="Get the text message associated with an HTTP status code"
+arch=('any')
+depends=('perl6')
+checkdepends=('perl')
+makedepends=('alacryd' 'git')
+groups=('perl6')
+url="https://github.com/supernovus/perl6-http-status"
+license=('PerlArtistic')
+source=($pkgname-$pkgver::git+https://github.com/supernovus/perl6-http-status)
+sha256sums=('SKIP')
+
+check() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ msg2 'Running tests...'
+ PERL6LIB=lib prove -r -e perl6
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ msg2 'Installing documentation...'
+ install -Dm 644 README -t "$pkgdir/usr/share/doc/$pkgname"
+
+ msg2 'Installing...'
+ install -dm 755 "$pkgdir/usr/share/perl6/vendor"
+ export RAKUDO_LOG_PRECOMP=1
+ export PERL6LIB="inst#$pkgdir/usr/share/perl6/vendor"
+ alacryd install
+
+ msg2 'Removing redundant precomp file dependencies...'
+ _precomp=($(pacman -Qg perl6 \
+ | awk '{print $2}' \
+ | xargs pacman -Ql \
+ | awk '{print $2}' \
+ | grep precomp))
+ for _pc in "${_precomp[@]}"; do
+ [[ -f "$pkgdir/$_pc" ]] && rm -f "$pkgdir/$_pc"
+ done
+
+ msg2 'Cleaning up pkgdir...'
+ find "$pkgdir" -type f -name "*.lock" -exec rm '{}' \;
+}